sim: testsuite: tweak parallel find invocation [PR sim/29596]

Message ID 20221023191654.28740-1-vapier@gentoo.org
State Committed
Headers
Series sim: testsuite: tweak parallel find invocation [PR sim/29596] |

Commit Message

Mike Frysinger Oct. 23, 2022, 7:16 p.m. UTC
  Make sure we invoke runtest with the same exp filenames when running in
parallel as it will find when run single threaded.  When `runtest` finds
files itself, it will use paths like "aarch64/allinsn.exp".  When we run
`find .` with the %p option, it produces "./aarch64/allinsn.exp".  Switch
to %P to get "aarch64/allinsn.exp".

Bug: https://sourceware.org/PR29596
---
 sim/Makefile.in        | 2 +-
 sim/testsuite/local.mk | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)
  

Patch

diff --git a/sim/testsuite/local.mk b/sim/testsuite/local.mk
index c1799c728ae7..e55f8c3c8b22 100644
--- a/sim/testsuite/local.mk
+++ b/sim/testsuite/local.mk
@@ -49,7 +49,7 @@  check/%.exp:
 check-DEJAGNU-parallel:
 	$(AM_V_at)( \
 	$(MAKE) -k \
-	  `cd $(srcdir)/testsuite && find . -name '*.exp' -printf 'check/%p '`; \
+	  `cd $(srcdir)/testsuite && find . -name '*.exp' -printf 'check/%P '`; \
 	ret=$$?; \
 	$(SHELL) $(srcroot)/contrib/dg-extract-results.sh \
 	  `find testsuite/ -maxdepth 4 -name testrun.sum | sort` > testrun.sum; \