sim/rx/gdb-if.c variable name collision
Commit Message
> I built binutils (from master) for linux without problems.
>
> When I try to build the same source/target but now using x64-mingw32 I get a name collision with a local variable name “open” declared in line 64 of/sim/rx/gdb-if.c,
>
> used in lines 64,82 and 101.
Thanks for the report.
> Could this variable be renamed? And commited?
>
> Once renamed the compilation went fine.
>
> I'm not aware of the naming conventions used by gdb people this is why
> I didn't propose a patch.
Often, we'll use a prefix. In this case, I used "rx_", and renamed
the variable to "rx_sim_is_open".
sim/rx/ChangeLog:
* gdb-if.c (open): Rename to...
(rx_sim_is_open): This. Replace all uses of "open" by uses of
"rx_sim_is_open" throughout.
Tested by rebuilding on x86_64-linux. Pushed on master and gdb-7.9-branch.
From a300380e12ca04a6cb900e9bfd26161b3fe56ed8 Mon Sep 17 00:00:00 2001
From: Joel Brobecker <brobecker@adacore.com>
Date: Thu, 15 Jan 2015 07:14:45 +0400
Subject: [PATCH] Build failure in sim/rx/gdb-if.c on windows
This should fix a build failure reported on x86_64-mingw32 by Daniel
Calcoen due to conflicting declarations of "open". This patch just
renames the static global in sim/rx/gdb-if.c into "rx_sim_is_open".
sim/rx/ChangeLog:
* gdb-if.c (open): Rename to...
(rx_sim_is_open): This. Replace all uses of "open" by uses of
"rx_sim_is_open" throughout.
Tested by rebuilding on x86_64-linux.
---
sim/rx/ChangeLog | 6 ++++++
sim/rx/gdb-if.c | 8 ++++----
2 files changed, 10 insertions(+), 4 deletions(-)
@@ -1,3 +1,9 @@
+2015-12-15 Joel Brobecker <brobecker@adacore.com>
+
+ * gdb-if.c (open): Rename to...
+ (rx_sim_is_open): This. Replace all uses of "open" by uses of
+ "rx_sim_is_open" throughout.
+
2014-08-19 Alan Modra <amodra@gmail.com>
* configure: Regenerate.
@@ -54,14 +54,14 @@ static struct sim_state the_minisim = {
"This is the sole rx minisim instance. See libsim.a's global variables."
};
-static int open;
+static int rx_sim_is_open;
SIM_DESC
sim_open (SIM_OPEN_KIND kind,
struct host_callback_struct *callback,
struct bfd *abfd, char **argv)
{
- if (open)
+ if (rx_sim_is_open)
fprintf (stderr, "rx minisim: re-opened sim\n");
/* The 'run' interface doesn't use this function, so we don't care
@@ -79,7 +79,7 @@ sim_open (SIM_OPEN_KIND kind,
execution_error_init_debugger ();
sim_disasm_init (abfd);
- open = 1;
+ rx_sim_is_open = 1;
return &the_minisim;
}
@@ -98,7 +98,7 @@ sim_close (SIM_DESC sd, int quitting)
/* Not much to do. At least free up our memory. */
init_mem ();
- open = 0;
+ rx_sim_is_open = 0;
}
static bfd *
--
1.9.1