From patchwork Sun Nov 7 18:18:03 2021 Content-Type: text/plain; charset="utf-8" MIME-Version: 1.0 Content-Transfer-Encoding: 7bit X-Patchwork-Submitter: Thomas Koenig X-Patchwork-Id: 47194 Return-Path: X-Original-To: patchwork@sourceware.org Delivered-To: patchwork@sourceware.org Received: from server2.sourceware.org (localhost [IPv6:::1]) by sourceware.org (Postfix) with ESMTP id 091B93858429 for ; Sun, 7 Nov 2021 18:18:55 +0000 (GMT) DKIM-Filter: OpenDKIM Filter v2.11.0 sourceware.org 091B93858429 DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gcc.gnu.org; s=default; t=1636309135; bh=hiuPb5S+N6hGGtzpe8jn3Mv5GkJsxv5rQnM56BDsRFM=; h=To:Subject:Date:List-Id:List-Unsubscribe:List-Archive:List-Post: List-Help:List-Subscribe:From:Reply-To:From; b=YRqe0yve/pjo37u9Q68YJp8ZJDE6K//Tpf9DrKuSJa+D9pK3PTHpzTNTifWrNn7tY b/TRR+ZCHH9VjbnNiLzm4zXDpG89HHVeGKwIMaCGowPq7tSuabDYpLHPG7wizI/Mte 8w3pfRBfntkbHcNL8ksdNjD1Ng9TD2WxU2D9Unm0= X-Original-To: gcc-patches@gcc.gnu.org Delivered-To: gcc-patches@gcc.gnu.org Received: from cc-smtpout3.netcologne.de (cc-smtpout3.netcologne.de [IPv6:2001:4dd0:100:1062:25:2:0:3]) by sourceware.org (Postfix) with ESMTPS id 1875A3858401; Sun, 7 Nov 2021 18:18:08 +0000 (GMT) DMARC-Filter: OpenDMARC Filter v1.4.1 sourceware.org 1875A3858401 Received: from cc-smtpin2.netcologne.de (cc-smtpin2.netcologne.de [89.1.8.202]) by cc-smtpout3.netcologne.de (Postfix) with ESMTP id C440E123F1; Sun, 7 Nov 2021 19:18:04 +0100 (CET) Received: from [IPv6:2001:4dd7:f84d:0:7285:c2ff:fe6c:992d] (2001-4dd7-f84d-0-7285-c2ff-fe6c-992d.ipv6dyn.netcologne.de [IPv6:2001:4dd7:f84d:0:7285:c2ff:fe6c:992d]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange X25519 server-signature RSA-PSS (2048 bits) server-digest SHA256) (No client certificate requested) by cc-smtpin2.netcologne.de (Postfix) with ESMTPSA id 7870B11E10; Sun, 7 Nov 2021 19:18:03 +0100 (CET) To: "fortran@gcc.gnu.org" , gcc-patches Subject: [patch, fortran, wwwdocs] Fix name of argument to CO_REDUCE Message-ID: <1ebfa54c-b2c5-7cd3-9168-c19a778cd3ce@netcologne.de> Date: Sun, 7 Nov 2021 19:18:03 +0100 User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:78.0) Gecko/20100101 Thunderbird/78.13.0 MIME-Version: 1.0 Content-Language: en-US X-NetCologne-Spam: L X-Rspamd-Queue-Id: 7870B11E10 X-Spam-Status: No, score=-10.6 required=5.0 tests=BAYES_00, DKIM_SIGNED, DKIM_VALID, DKIM_VALID_AU, DKIM_VALID_EF, GIT_PATCH_0, RCVD_IN_DNSWL_LOW, SPF_HELO_NONE, SPF_PASS, TXREP autolearn=ham autolearn_force=no version=3.4.4 X-Spam-Checker-Version: SpamAssassin 3.4.4 (2020-01-24) on server2.sourceware.org X-BeenThere: gcc-patches@gcc.gnu.org X-Mailman-Version: 2.1.29 Precedence: list List-Id: Gcc-patches mailing list List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , X-Patchwork-Original-From: Thomas Koenig via Gcc-patches From: Thomas Koenig Reply-To: Thomas Koenig Errors-To: gcc-patches-bounces+patchwork=sourceware.org@gcc.gnu.org Sender: "Gcc-patches" Hello world, the attached patches fix the name of the function argument to CO_REDUCE to conform to Fortran 2018 instead of the TR. This is a user-visible change, so I have put this both into changes.html and porting_to.html. Regression-tested. OK for trunk? Best regards Thomas Author: Thomas Koenig Date: 2021-11-07 15:38:35 +0100 Fix keyword name for co_reduce. gcc/fortran/ChangeLog: * intrinsic.c (add_subroutines): Change keyword "operator" to the correct one, "operation". * check.c (gfc_check_co_reduce): Change OPERATOR to OPERATION in error messages. gcc/testsuite/ChangeLog: * gfortran.dg/co_reduce_2.f90: New test. * gfortran.dg/coarray_collective_16.f90: Change OPERATOR to OPERATION. * gfortran.dg/coarray_collective_9.f90: Likewise. Co-authored by: Steve Kargl diff --git a/htdocs/gcc-12/changes.html b/htdocs/gcc-12/changes.html index 5974b9ba..7d0c04f9 100644 --- a/htdocs/gcc-12/changes.html +++ b/htdocs/gcc-12/changes.html @@ -157,6 +157,12 @@ a work-in-progress.

have been fixed, and an extensive set of new conformance test cases has been added. +
  • + GCC 12 now uses OPERATION as the name of the function to + the CO_REDUCE intrinsic for the pairwise reduction, thus + conforming to the Fortran 2018 standard. Previous versions + used OPERATOR, which conformed to TS 18508. +
  • diff --git a/htdocs/gcc-12/porting_to.html b/htdocs/gcc-12/porting_to.html index 9154d7b3..42179c11 100644 --- a/htdocs/gcc-12/porting_to.html +++ b/htdocs/gcc-12/porting_to.html @@ -57,7 +57,13 @@ is no longer accepted and you need to add a cast to it like: +

    Argument name for CO_REDUCE

    +

    +GCC 12 now uses OPERATION as the name of the function to +the CO_REDUCE intrinsic for the pairwise reduction, thus +conforming to the Fortran 2018 standard. Previous versions +used OPERATOR, which conformed to TS 18508.