diff mbox series

[2/2] Update the section on binutils version

Message ID 1631928115-7493-2-git-send-email-apinski@marvell.com
State Committed
Commit 7e4ada576fe5297e794ca20803e010ed0212fb7e
Headers show
Series [1/2] Fix PR bootstrap/102389: --with-build-config=bootstrap-lto is broken | expand

Commit Message

apinski--- via Gcc-patches Sept. 18, 2021, 1:21 a.m. UTC
From: Andrew Pinski <apinski@marvell.com>

LTO usage requires binutils 2.35 or newer due to
https://sourceware.org/PR25355.
This adds a note in the prerequisites page about it.

Ok?

gcc/ChangeLog:

	* doc/install.texi: Add note about
	binutils 2.35 is required for LTO usage.
---
 gcc/doc/install.texi | 3 +++
 1 file changed, 3 insertions(+)

Comments

Jeff Law Sept. 19, 2021, 4:52 p.m. UTC | #1
On 9/17/2021 7:21 PM, apinski--- via Gcc-patches wrote:
> From: Andrew Pinski <apinski@marvell.com>
>
> LTO usage requires binutils 2.35 or newer due to
> https://sourceware.org/PR25355.
> This adds a note in the prerequisites page about it.
>
> Ok?
>
> gcc/ChangeLog:
>
> 	* doc/install.texi: Add note about
> 	binutils 2.35 is required for LTO usage.
> ---
OK
jeff
diff mbox series

Patch

diff --git a/gcc/doc/install.texi b/gcc/doc/install.texi
index 88e453c3f6b..a141507c7b0 100644
--- a/gcc/doc/install.texi
+++ b/gcc/doc/install.texi
@@ -325,6 +325,9 @@  Necessary in some circumstances, optional in others.  See the
 host/target specific instructions for your platform for the exact
 requirements.
 
+Note binutils 2.35 or newer is required for LTO to work correctly
+with GNU libtool that includes doing a bootstrap with LTO enabled.
+
 @item gzip version 1.2.4 (or later) or
 @itemx bzip2 version 1.0.2 (or later)