mbox series

[0/6] rs6000: Remove "old" built-in function infrastructure

Message ID cover.1638554381.git.wschmidt@linux.ibm.com
Headers show
Series rs6000: Remove "old" built-in function infrastructure | expand

Message

Bill Schmidt Dec. 3, 2021, 6:22 p.m. UTC
From: Bill Schmidt <wschmidt@linux.ibm.com>

Hi!

Now that the new built-in function support is all upstream and enabled, it
seems safe and prudent to remove the old code to avoid confusion.  I broke this
up to the extent possible, but the first patch is a bit large and messy because
so many dead functions have to be removed when taking out the
"new_builtins_are_live" variable.

Bill Schmidt (6):
  rs6000: Remove new_builtins_are_live and dead code it was guarding
  rs6000: Remove altivec_overloaded_builtins array and initialization
  rs6000: Rename rs6000-builtin-new.def to rs6000-builtins.def
  rs6000: Remove rs6000-builtin.def and associated data and functions
  rs6000: Rename functions with "new" in their names
  rs6000: Rename arrays to remove temporary _x suffix

 gcc/config/rs6000/darwin.h                    |     8 +-
 gcc/config/rs6000/rs6000-builtin.def          |  3350 ---
 ...00-builtin-new.def => rs6000-builtins.def} |     0
 gcc/config/rs6000/rs6000-c.c                  |  1342 +-
 gcc/config/rs6000/rs6000-call.c               | 17810 +++-------------
 gcc/config/rs6000/rs6000-gen-builtins.c       |   115 +-
 gcc/config/rs6000/rs6000-internal.h           |     2 +-
 gcc/config/rs6000/rs6000-protos.h             |     3 -
 gcc/config/rs6000/rs6000.c                    |   334 +-
 gcc/config/rs6000/rs6000.h                    |    58 -
 gcc/config/rs6000/t-rs6000                    |     7 +-
 11 files changed, 3173 insertions(+), 19856 deletions(-)
 delete mode 100644 gcc/config/rs6000/rs6000-builtin.def
 rename gcc/config/rs6000/{rs6000-builtin-new.def => rs6000-builtins.def} (100%)

Comments

Pop, Sebastian via Gcc-patches Dec. 6, 2021, 4:39 p.m. UTC | #1
I had difficulty with patch 1/6 being too large, and there have been some small
upstream changes in this area, so I will resubmit this series shortly.  There
were also problems with my SMTP server for some of the CCs as well...

Sorry for the churn!
Bill

On 12/3/21 12:22 PM, Bill Schmidt wrote:
> From: Bill Schmidt <wschmidt@linux.ibm.com>
>
> Hi!
>
> Now that the new built-in function support is all upstream and enabled, it
> seems safe and prudent to remove the old code to avoid confusion.  I broke this
> up to the extent possible, but the first patch is a bit large and messy because
> so many dead functions have to be removed when taking out the
> "new_builtins_are_live" variable.
>
> Bill Schmidt (6):
>   rs6000: Remove new_builtins_are_live and dead code it was guarding
>   rs6000: Remove altivec_overloaded_builtins array and initialization
>   rs6000: Rename rs6000-builtin-new.def to rs6000-builtins.def
>   rs6000: Remove rs6000-builtin.def and associated data and functions
>   rs6000: Rename functions with "new" in their names
>   rs6000: Rename arrays to remove temporary _x suffix
>
>  gcc/config/rs6000/darwin.h                    |     8 +-
>  gcc/config/rs6000/rs6000-builtin.def          |  3350 ---
>  ...00-builtin-new.def => rs6000-builtins.def} |     0
>  gcc/config/rs6000/rs6000-c.c                  |  1342 +-
>  gcc/config/rs6000/rs6000-call.c               | 17810 +++-------------
>  gcc/config/rs6000/rs6000-gen-builtins.c       |   115 +-
>  gcc/config/rs6000/rs6000-internal.h           |     2 +-
>  gcc/config/rs6000/rs6000-protos.h             |     3 -
>  gcc/config/rs6000/rs6000.c                    |   334 +-
>  gcc/config/rs6000/rs6000.h                    |    58 -
>  gcc/config/rs6000/t-rs6000                    |     7 +-
>  11 files changed, 3173 insertions(+), 19856 deletions(-)
>  delete mode 100644 gcc/config/rs6000/rs6000-builtin.def
>  rename gcc/config/rs6000/{rs6000-builtin-new.def => rs6000-builtins.def} (100%)
>