[v2] gprofng: avoid use of non-portable which [PR32166]
Checks
Context |
Check |
Description |
linaro-tcwg-bot/tcwg_binutils_build--master-arm |
success
|
Build passed
|
linaro-tcwg-bot/tcwg_binutils_build--master-aarch64 |
success
|
Build passed
|
linaro-tcwg-bot/tcwg_binutils_check--master-aarch64 |
success
|
Test passed
|
linaro-tcwg-bot/tcwg_binutils_check--master-arm |
success
|
Test passed
|
Commit Message
Distributions like Debian [0] and Gentoo are phasing out the use of
the non-portable `which` utility. Use POSIX's `command -v` instead.
[0] https://lwn.net/Articles/874049/
gprofng/ChangeLog
PR gprofng/32166
* testsuite/lib/Makefile.skel (JAVABIN): Replace use of which.
---
v2: Fix commit message.
gprofng/testsuite/lib/Makefile.skel | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
base-commit: ad0751b6ecf40cb94ecb693d1acfc38fd223f408
@@ -23,7 +23,7 @@ CFLAGS = -g -Wall
SHAREDOPT = -fpic -shared
#JAVABIN = /usr/java/latest/bin
-JAVABIN = $(shell dirname `which java`)
+JAVABIN = $(shell dirname `command -v java`)
JAVA = $(JAVABIN)/java
JAVAC = $(JAVABIN)/javac