Show patches with: Archived = No       |   7212 patches
« 1 2 3 472 73 »
Patch Series rb/tb S/W/F Date Submitter Delegate State
[4/5] readelf: fold get_{32,64}bit_dynamic_section() readelf: reduce code duplication a little - - 2-- 2026-07-27 Jan Beulich New
[3/5] readelf: fold get_{32,64}bit_elf_symbols() readelf: reduce code duplication a little - - 2-- 2026-07-27 Jan Beulich New
[2/5] readelf: fold get_{32,64}bit_section_headers() readelf: reduce code duplication a little - - 2-- 2026-07-27 Jan Beulich New
[1/5] readelf: fold get_{32,64}bit_program_headers() readelf: reduce code duplication a little - - 2-- 2026-07-27 Jan Beulich New
[v3] x86: Generate PLT32 relocation for ".long foo@PLT - .L4" [v3] x86: Generate PLT32 relocation for ".long foo@PLT - .L4" - - 4-- 2026-07-27 H.J. Lu New
Use ufile_ptr for file position Use ufile_ptr for file position - - --2 2026-07-27 Alan Modra New
DWARF1 AT_sibling sanity check DWARF1 AT_sibling sanity check - - --2 2026-07-27 Alan Modra New
regen ld/po/BLD-POTFILES.in regen ld/po/BLD-POTFILES.in - - --2 2026-07-27 Alan Modra New
[v2] x86: Generate PLT32 relocation for ".long foo@PLT - .L4" [v2] x86: Generate PLT32 relocation for ".long foo@PLT - .L4" - - 4-- 2026-07-27 H.J. Lu New
[v2] ld: Skip pr33265-2 and pr33265-3 tests on Windows. [v2] ld: Skip pr33265-2 and pr33265-3 tests on Windows. - - 4-- 2026-07-26 Jan Dubiec New
MIPS opcodes: fix transposed FS and FT in vadda and vmsuba MIPS opcodes: fix transposed FS and FT in vadda and vmsuba - - 4-- 2026-07-25 Piotr P. Stefaniak New
etc: import changes to texi2pod.pl from gcc etc: import changes to texi2pod.pl from gcc - - 4-- 2026-07-25 Andrew Burgess New
x86-64: Generate R_X86_64_PLT32 for ".long foo@PLT - .L4" x86-64: Generate R_X86_64_PLT32 for ".long foo@PLT - .L4" - - 4-- 2026-07-25 H.J. Lu New
[v2] gas: support for .pushsection and .popsection pseudo ops for coff [v2] gas: support for .pushsection and .popsection pseudo ops for coff - - 4-- 2026-07-24 Johannes Khoshnazar-Thoma New
[v2,6/6] Add nanoMIPS tests. Add support for nanoMIPS architecture - - 4-- 2026-07-24 Tsing New
[v2,5/6] Add nanoMIPS documentation. Add support for nanoMIPS architecture - - 4-- 2026-07-24 Tsing New
[v2,4/6] Readelf for nanoMIPS. Add support for nanoMIPS architecture - - 4-- 2026-07-24 Tsing New
[v2,3/6] Opcodes changes for nanoMIPS support. Add support for nanoMIPS architecture - - 4-- 2026-07-24 Tsing New
[v2,2/6] BFD changes for nanoMIPS support. Add support for nanoMIPS architecture - - 4-- 2026-07-24 Tsing New
[v2,1/6] Gas changes for nanoMIPS support. Add support for nanoMIPS architecture - - 4-- 2026-07-24 Tsing New
[4/4] x86: move operand_types[] out of struct insn_template x86: operand types handling in gas - - 4-- 2026-07-24 Jan Beulich New
[3/4] x86: helper function + variables for templates' ->operand_types[] accesses x86: operand types handling in gas - - 4-- 2026-07-24 Jan Beulich New
[2/4] x86: correct operand_types[] used in build_vex_prefix() x86: operand types handling in gas - - 4-- 2026-07-24 Jan Beulich New
[1/4] x86: copy template's .operand_types[] into global insn data x86: operand types handling in gas - - 4-- 2026-07-24 Jan Beulich New
[v4,12/12] RISC-V/bfd: warn about non-power-of-2 stack-align attribute RISC-V: assorted fixes and (hopefully) improvements 1 - 4-- 2026-07-24 Jan Beulich New
[v4,11/12] RISC-V/bfd: warn about non-boolean unaligned-access attribute RISC-V: assorted fixes and (hopefully) improvements 1 - 4-- 2026-07-24 Jan Beulich New
[v4,10/12] RISC-V/gas: warn about non-power-of-2 stack-align attribute RISC-V: assorted fixes and (hopefully) improvements 1 - 4-- 2026-07-24 Jan Beulich New
[v4,09/12] RISC-V/gas: warn about non-boolean unaligned-access attribute RISC-V: assorted fixes and (hopefully) improvements 1 - 4-- 2026-07-24 Jan Beulich New
[v4,08/12] RISC-V/gas: .attribute vs .insn RISC-V: assorted fixes and (hopefully) improvements 1 - 4-- 2026-07-24 Jan Beulich New
[v4,07/12] RISC-V: check operands for Zqinx RISC-V: assorted fixes and (hopefully) improvements - - 4-- 2026-07-24 Jan Beulich New
[v4,06/12] RISC-V: check operands for Zdinx in RV32 RISC-V: assorted fixes and (hopefully) improvements - - 4-- 2026-07-24 Jan Beulich New
[v4,05/12] RISC-V: make FP rounding mode an optional operand RISC-V: assorted fixes and (hopefully) improvements - - 4-- 2026-07-24 Jan Beulich New
[v4,04/12] RISC-V: drop FCVT.Q.L{,U} forms with rounding mode operand RISC-V: assorted fixes and (hopefully) improvements - - 4-- 2026-07-24 Jan Beulich New
[v4,03/12] RISC-V: replace INSN_V_EEW64 RISC-V: assorted fixes and (hopefully) improvements - - 3-- 2026-07-24 Jan Beulich New
[v4,02/12] bfd/RISC-V: Zve{32,64}f don't need to explicitly imply Zvl{32,64}b RISC-V: assorted fixes and (hopefully) improvements - - 1-- 2026-07-24 Jan Beulich New
[v4,01/12] bfd/RISC-V: Zv{b,k}* imply Zve32x RISC-V: assorted fixes and (hopefully) improvements - - --- 2026-07-24 Jan Beulich New
AArch64: Optimize ADD relocations that resolve to zero AArch64: Optimize ADD relocations that resolve to zero - - 4-- 2026-07-24 Sivan Shani Changes Requested
aarch64: remove casts from more struct initializers aarch64: remove casts from more struct initializers - - 4-- 2026-07-24 Jan Beulich Committed
RISC-V: define elf_backend_dtrel_excludes_plt RISC-V: define elf_backend_dtrel_excludes_plt - - 4-- 2026-07-24 wangjue New
PR 30308 more unbounded recursion PR 30308 more unbounded recursion - - --2 2026-07-23 Alan Modra New
[v3,1/1] aarch64: mingw: Prevent relocation types from being overwritten aarch64: mingw: Prevent relocation types from being overwritten - - 4-- 2026-07-22 Evgeny Karpov Superseded
PR 34418 alpha_vms_slurp_relocs off-by-one section index check PR 34418 alpha_vms_slurp_relocs off-by-one section index check - - --2 2026-07-22 Alan Modra New
ld: Unify the directory separator on Windows. ld: Unify the directory separator on Windows. - - 4-- 2026-07-22 Jan Dubiec New
[RFC] LoongArch: Add parameters to DWARF2_USE_FIXED_ADVANCE_PC macro [RFC] LoongArch: Add parameters to DWARF2_USE_FIXED_ADVANCE_PC macro - - -2- 2026-07-22 mengqinggang New
LD/testsuite: Remove $LDFLAGS reference from `run_ld_link_tests' LD/testsuite: Remove $LDFLAGS reference from `run_ld_link_tests' - - 4-- 2026-07-21 Maciej W. Rozycki New
testsuite: Also exclude `*-*-kfreebsd*-gnu' from STB_GNU_UNIQUE tests testsuite: Also exclude `*-*-kfreebsd*-gnu' from STB_GNU_UNIQUE tests - - 4-- 2026-07-21 Maciej W. Rozycki New
AVR: Sort .text.* input sections by their name. AVR: Sort .text.* input sections by their name. - - --2 2026-07-20 Georg-Johann Lay New
Derive ld's noconfigdirs entry from ld/configure.tgt (was: Re: [PATCH] bfd: recognize *-*-windows* … Derive ld's noconfigdirs entry from ld/configure.tgt (was: Re: [PATCH] bfd: recognize *-*-windows* … - - 4-- 2026-07-20 Pedro Alves New
[v2] RISC-V: Add new relocation types for global array accesses with non-constant indices [v2] RISC-V: Add new relocation types for global array accesses with non-constant indices - - --2 2026-07-20 Liqin Weng New
[v2] RISC-V: Add new relocation types for global array accesses with non-constant indices [v2] RISC-V: Add new relocation types for global array accesses with non-constant indices - - --2 2026-07-20 Liqin Weng New
gas: support for .pushsection and .popsection pseudo ops for coff gas: support for .pushsection and .popsection pseudo ops for coff - - 4-- 2026-07-18 Johannes Khoshnazar-Thoma New
ld: testsuite: Associate C identifiers with the corresponding assembler or linker symbols in a targ… ld: testsuite: Associate C identifiers with the corresponding assembler or linker symbols in a targ… - - --2 2026-07-18 Jan Dubiec New
ld: testsuite: Fix integer overflow in ld/testsuite/ld-elf/init-mixed.c. ld: testsuite: Fix integer overflow in ld/testsuite/ld-elf/init-mixed.c. - - 4-- 2026-07-17 Jan Dubiec New
[2/2] x86: fold F16C templates with their AVX512VL counterparts x86: AVX512VL adjustments - - 4-- 2026-07-17 Jan Beulich New
[1/2] x86: correct implied-AVX512VL checking x86: AVX512VL adjustments - - 4-- 2026-07-17 Jan Beulich New
[6/6] Add nanoMIPS tests. Add support for nanoMIPS architecture - - 4-- 2026-07-17 Tsing New
[5/6] Add nanoMIPS documentation. Add support for nanoMIPS architecture - - 4-- 2026-07-17 Tsing New
[4/6] Readelf for nanoMIPS. Add support for nanoMIPS architecture - - 4-- 2026-07-17 Tsing New
[3/6] Opcodes changes for nanoMIPS support. Add support for nanoMIPS architecture - - 4-- 2026-07-17 Tsing New
[2/6] BFD changes for nanoMIPS support. Add support for nanoMIPS architecture - - 4-- 2026-07-17 Tsing New
[1/6] Gas changes for nanoMIPS support. Add support for nanoMIPS architecture - - 4-- 2026-07-17 Tsing New
ld: testsuite: Fix a few backslash-related issues on MinGW. ld: testsuite: Fix a few backslash-related issues on MinGW. - - 4-- 2026-07-17 Jan Dubiec New
[3/3] x86: simplify one case of base opcode setting in optimize_encoding() x86: tweaks to optimize_encoding() - - 4-- 2026-07-17 Jan Beulich New
[2/3] x86: simplify expressions checking register operand properties x86: tweaks to optimize_encoding() - - 4-- 2026-07-17 Jan Beulich New
[1/3] x86: slightly simplify VPBROADCASTQ -> VUNPCKLQDQ optimization again x86: tweaks to optimize_encoding() - - 4-- 2026-07-17 Jan Beulich New
loongarch gcc-4.9 build error loongarch gcc-4.9 build error - - --2 2026-07-17 Alan Modra New
[v12,1/1] aarch64: Implement Structured Exception Handling (SEH) on AArch64 Implement Structured Exception Handling (SEH) on AArch64 - - 4-- 2026-07-16 Evgeny Karpov Superseded
aarch64: Remove cast from struct initializer aarch64: Remove cast from struct initializer - - --2 2026-07-15 Alice Carlotti Committed
[v4] PE/COFF: raise normal PE section limit safely [v4] PE/COFF: raise normal PE section limit safely - - 4-- 2026-07-14 Oleg Tolmatcev New
[v2] LoongArch: only insert align section for ld -r if an input has R_LARCH_ALIGN or R_LARCH_RELAX [v2] LoongArch: only insert align section for ld -r if an input has R_LARCH_ALIGN or R_LARCH_RELAX - - 4-- 2026-07-14 Xi Ruoyao New
[RFC,v3,4/4] RX: rx-linux target FDPIC support Add FDPIC support for Renesas RX - - -2- 2026-07-14 Yoshinori Sato New
[RFC,v3,3/4] RX: ld rx-linux target FDPIC support Add FDPIC support for Renesas RX - - -2- 2026-07-14 Yoshinori Sato New
[RFC,v3,2/4] RX: gas rx-linux target FDPIC support Add FDPIC support for Renesas RX - - -2- 2026-07-14 Yoshinori Sato New
[RFC,v3,1/4] RX: bfd rx-linux FDPIC support Add FDPIC support for Renesas RX - - -2- 2026-07-14 Yoshinori Sato New
LoongArch: only insert align section for ld -r if an input has R_LARCH_ALIGN LoongArch: only insert align section for ld -r if an input has R_LARCH_ALIGN - - 4-- 2026-07-14 Xi Ruoyao New
RISC-V: Add Zama16b extension support RISC-V: Add Zama16b extension support - - 4-- 2026-07-14 Wang Yaduo New
bfd: recognize *-*-windows* Windows targets bfd: recognize *-*-windows* Windows targets - - 4-- 2026-07-13 Pedro Alves New
libctf: bounds-check forward ctt_type before indexing pop[] libctf: bounds-check forward ctt_type before indexing pop[] - - 4-- 2026-07-13 Naveed Khan New
x86: Disable XCHG to MOV optimization x86: Disable XCHG to MOV optimization - - 4-- 2026-07-13 H.J. Lu New
arm: remove stray backslash in warning message arm: remove stray backslash in warning message - - --2 2026-07-12 Alan Modra New
aarch64-pe fails of tls-debug tests aarch64-pe fails of tls-debug tests - - --2 2026-07-11 Alan Modra Committed
[v3,2/2] ld testsuite: Update "__patchable_function_entries section [2-6]" test cases [v3,1/2] H8: Set H8/300H as the default architecture for the H8 family - - 1-2 2026-07-11 Jan Dubiec New
[v3,1/2] H8: Set H8/300H as the default architecture for the H8 family [v3,1/2] H8: Set H8/300H as the default architecture for the H8 family - - --2 2026-07-11 Jan Dubiec New
[committed] aarch64: Add support for FEAT_SME_FA64 [committed] aarch64: Add support for FEAT_SME_FA64 - - --2 2026-07-10 Alice Carlotti Committed
[committed] aarch64: Update FEAT_TPS and FEAT_TPSP system registers [committed] aarch64: Update FEAT_TPS and FEAT_TPSP system registers - - --2 2026-07-10 Alice Carlotti Committed
[v2,2/2] ld testsuite: Update "__patchable_function_entries section [2-6]" test cases [v2,1/2] H8: Set H8/300H as the default architecture for the H8 family - - 4-- 2026-07-10 Jan Dubiec New
[v2,1/2] H8: Set H8/300H as the default architecture for the H8 family [v2,1/2] H8: Set H8/300H as the default architecture for the H8 family - - 1-2 2026-07-10 Jan Dubiec New
x86: separate AVX10.1-aux from AVX10.2 x86: separate AVX10.1-aux from AVX10.2 - - --2 2026-07-10 Jan Beulich New
x86: avoid duplication of testcase expectations in ilp32/ x86: avoid duplication of testcase expectations in ilp32/ - - 4-- 2026-07-10 Jan Beulich New
x86: accept LOCK on control register accesses only with ModR/M.reg == 0 x86: accept LOCK on control register accesses only with ModR/M.reg == 0 - - 4-- 2026-07-10 Jan Beulich New
[v3] LoongArch: Support R_LARCH_TLS_DTPREL32/64 used in debug section [v3] LoongArch: Support R_LARCH_TLS_DTPREL32/64 used in debug section - - --2 2026-07-10 mengqinggang New
H8: Set H8/300H as the default architecture for H8 family H8: Set H8/300H as the default architecture for H8 family - - 4-- 2026-07-09 Jan Dubiec New
[5/5] readelf: Consolidate get_[32|64]bit_dynamic_section readelf.c: Consolidating get_[32|64]bit_XXX into get_XXX - - 4-- 2026-07-09 H.J. Lu New
[4/5] readelf: Consolidate get_[32|64]bit_elf_symbols readelf.c: Consolidating get_[32|64]bit_XXX into get_XXX - - 4-- 2026-07-09 H.J. Lu New
[3/5] readelf: Consolidate get_[32|64]bit_program_headers readelf.c: Consolidating get_[32|64]bit_XXX into get_XXX - - 4-- 2026-07-09 H.J. Lu New
[2/5] readelf: Use BYTE_GET_SIZE in RELR relocation processing readelf.c: Consolidating get_[32|64]bit_XXX into get_XXX - - 4-- 2026-07-09 H.J. Lu New
[1/5] readelf: Consolidate get_[32|64]bit_section_headers readelf.c: Consolidating get_[32|64]bit_XXX into get_XXX - - 4-- 2026-07-09 H.J. Lu New
[pushed] AVR: Fix typo / white space in include/opcode/avr.h [pushed] AVR: Fix typo / white space in include/opcode/avr.h - - --2 2026-07-09 Georg-Johann Lay New
readelf: attach location views to DW_LLE_startx_endx/startx_length loclists readelf: attach location views to DW_LLE_startx_endx/startx_length loclists - - 4-- 2026-07-09 Kamil Bucki \(Nokia\) New
[committed] RISC-V: Minor cleanup for opcodes/riscv-opc.c [committed] RISC-V: Minor cleanup for opcodes/riscv-opc.c - - --2 2026-07-09 Nelson Chu New
« 1 2 3 472 73 »