[V2] AArch64 pauth: Indicate unmasked addresses in backtrace

Message ID F3D7A960-329A-4BDA-A251-87828CF3E459@arm.com
State New, archived
Headers

Commit Message

Alan Hayward Aug. 8, 2019, 8:55 a.m. UTC
  > On 7 Aug 2019, at 20:24, Pedro Alves <palves@redhat.com> wrote:
> 
> On 7/30/19 3:41 PM, Alan Hayward wrote:
> 
>> diff --git a/gdb/doc/gdb.texinfo b/gdb/doc/gdb.texinfo
>> index 0fcd131f71..b7dba2f918 100644
>> --- a/gdb/doc/gdb.texinfo
>> +++ b/gdb/doc/gdb.texinfo
>> @@ -24380,6 +24380,14 @@ but the lengths of the @code{z} and @code{p} registers will not change.  This
>> is a known limitation of @value{GDBN} and does not affect the execution of the
>> target process.
>> 
>> +@subsubsection AArch64 Pointer Authentication.
>> +@cindex AArch64 Pointer Authentication.
>> +
>> +When @value{GDBN} is debugging the AArch64 architecture, and the program is
>> +using the v8.3-A feature Pointer Authentication (PAC), then whenever the link
>> +register @code{$lr} is pointing to an PAC function it's value will be masked.
> 
> s/it's value/its value/
> 
>> +When GDB prints a backtrace, any addresses that required unmasking will be
>> +postfixed with the marker [PAC].
>> 
> 
>> diff --git a/gdb/python/py-framefilter.c b/gdb/python/py-framefilter.c
>> index a2a96ac0d3..d805ec68f2 100644
>> --- a/gdb/python/py-framefilter.c
>> +++ b/gdb/python/py-framefilter.c
>> @@ -901,6 +901,8 @@ py_print_frame (PyObject *filter, frame_filter_flags flags,
>> 	    {
>> 	      annotate_frame_address ();
>> 	      out->field_core_addr ("addr", gdbarch, address);
>> +	      if (get_frame_pc_masked (frame))
>> +		out->field_string ("pac", " [PAC]");
>> 	      annotate_frame_address_end ();
>> 	      out->text (" in ");
>> 	    }
>> diff --git a/gdb/stack.c b/gdb/stack.c
>> index 7833ca4aeb..9d49809895 100644
>> --- a/gdb/stack.c
>> +++ b/gdb/stack.c
>> @@ -1298,7 +1298,11 @@ print_frame (const frame_print_options &fp_opts,
>> 	{
>> 	  annotate_frame_address ();
>> 	  if (pc_p)
>> -	    uiout->field_core_addr ("addr", gdbarch, pc);
>> +	    {
>> +	      uiout->field_core_addr ("addr", gdbarch, pc);
>> +	      if (get_frame_pc_masked (frame))
>> +		uiout->field_string ("pac", " [PAC]");
> 
> Hmm, I had suggested considering MI in the previous iteration, but
> I was just thinking of including the "[PAC]" text in the
> "addr" field.  If we're adding a new field, then a few extra
> things need to be considered:
> 
> #1 - documentation, both manual and NEWS should mention this new MI field.
> 
> #2 - calling the attribute "pac" makes it architecture specific. 
>      I.e., to make use of it, a frontend will have to have Aarch64 awareness?
>      Not sure that is a good thing.
> 
> #3 - The MI attribute is called "pac", and its content is
>      literally " [PAC]".  I'd find that odd if I were a frontend author:
>      the content is right aligned with a space, making doing anything with
>      it other than appending it to the address text probably look odd,
>      unless you bake in awareness of the attribute's text...  If I saw
>      an attribute named "pac", I'd expect it to be a boolean?  At the
>      least, the left space should not be part of the field, I think?
>      Maybe we should rename the field to something else, like "addr_attr"
>     for "address attributes" or something.


I hadn’t realised the implications doing that would have, and had assumed
you couldn’t add to a field that had already been used.

I had (prematurely) pushed the patch. Is this additional fix ok?

Alan.



    Move backtrace PAC marker into addr field

    PAC does not need its own field and should instead be part of
    the addr field.

    gdb/ChangeLog:

    2019-08-08  Alan Hayward  <alan.hayward@arm.com>

            * stack.c (print_frame): Move PAC into addr field.

    gdb/doc/ChangeLog:

    2019-08-08  Alan Hayward  <alan.hayward@arm.com>

            * gdb.texinfo (AArch64 Pointer Authentication): Fix typo.
  

Comments

Pedro Alves Aug. 8, 2019, 10:33 a.m. UTC | #1
On 8/8/19 9:55 AM, Alan Hayward wrote:

>     gdb/doc/ChangeLog:
> 
>     2019-08-08  Alan Hayward  <alan.hayward@arm.com>
> 
>             * gdb.texinfo (AArch64 Pointer Authentication): Fix typo.

Please merge this part as obvious.

> I hadn’t realised the implications doing that would have, and had assumed
> you couldn’t add to a field that had already been used.
> 
> I had (prematurely) pushed the patch. Is this additional fix ok?

I don't think so,

> diff --git a/gdb/stack.c b/gdb/stack.c
> index 0859815baf..c599caf51c 100644
> --- a/gdb/stack.c
> +++ b/gdb/stack.c
> @@ -1301,7 +1301,7 @@ print_frame (const frame_print_options &fp_opts,
>             {
>               uiout->field_core_addr ("addr", gdbarch, pc);
>               if (get_frame_pc_masked (frame))
> -               uiout->field_string ("pac", " [PAC]");
> +               uiout->field_string ("addr", " [PAC]");
>             }
>           else
>             uiout->field_string ("addr", "<unavailable>",
> 

... because I think that this results in MI printing two different "addr" attributes.

Instead, you'll need to build a string, with e.g., string_printf,
and use uiout->field_string with ui_out_style_kind::ADDRESS style,
so that MI outputs one single "addr" attribute.

Please try "gdb -i=mi".  You can still type CLI commands, so just "(gdb) start"
and running to main, so that GDB prints the frame in the *stop event should
be sufficient to trigger this.

BTW, there are two other places where we output the "addr" field
in the file.  Do you want to include "[PAC]" in those?  If so,
then factoring out the "addr" printing to a separate function
would be appropriate.

Thanks,
Pedro Alves
  
Alan Hayward Aug. 9, 2019, 1:22 p.m. UTC | #2
> On 8 Aug 2019, at 11:33, Pedro Alves <palves@redhat.com> wrote:

> 

> On 8/8/19 9:55 AM, Alan Hayward wrote:

> 

>> diff --git a/gdb/stack.c b/gdb/stack.c

>> index 0859815baf..c599caf51c 100644

>> --- a/gdb/stack.c

>> +++ b/gdb/stack.c

>> @@ -1301,7 +1301,7 @@ print_frame (const frame_print_options &fp_opts,

>>            {

>>              uiout->field_core_addr ("addr", gdbarch, pc);

>>              if (get_frame_pc_masked (frame))

>> -               uiout->field_string ("pac", " [PAC]");

>> +               uiout->field_string ("addr", " [PAC]");

>>            }

>>          else

>>            uiout->field_string ("addr", "<unavailable>",

>> 

> 

> ... because I think that this results in MI printing two different "addr" attributes.

> 

> Instead, you'll need to build a string, with e.g., string_printf,

> and use uiout->field_string with ui_out_style_kind::ADDRESS style,

> so that MI outputs one single "addr" attribute.

> 

> Please try "gdb -i=mi".  You can still type CLI commands, so just "(gdb) start"

> and running to main, so that GDB prints the frame in the *stop event should

> be sufficient to trigger this.


stop doesn’t trigger a PAC because it’s only once we reference a function via the
link register that the PAC unmasking happens.

However, selecting a previous frame does.... and the issues are obvious now:

=thread-selected,id="1",frame={level="1",addr="0x00000000004005b0",pac=" [PAC]",func="main3",args=[],file="cbreak-3.c",fullname="/root/cbreak-3.c",line="9",arch="aarch64"}


> 

> BTW, there are two other places where we output the "addr" field

> in the file.  Do you want to include "[PAC]" in those?  If so,

> then factoring out the "addr" printing to a separate function

> would be appropriate.

> 


Ok, I can do that.




> On 8 Aug 2019, at 17:58, Tom Tromey <tom@tromey.com> wrote:

> 

>>>>>> "Pedro" == Pedro Alves <palves@redhat.com> writes:

> 

> Pedro> Hmm, I had suggested considering MI in the previous iteration, but

> Pedro> I was just thinking of including the "[PAC]" text in the

> Pedro> "addr" field.  If we're adding a new field, then a few extra

> Pedro> things need to be considered:

> 

> Pedro>  #1 - documentation, both manual and NEWS should mention this new MI field.

> 

> Oops, I forgot about this.  Sorry about that.


I’ll add something.

> 

> I don't think putting this information into the "addr" field is a good

> idea.  It's better, IMO, to let MI field names provide the structure,

> rather than requiring clients to also parse the values of fields.

> 

> I realize MI isn't 100% clean on this topic, but we can still not make

> it worse.

> 

> Pedro>  #2 - calling the attribute "pac" makes it architecture specific. 

> 

> I don't think this is such a big deal but at the same time any

> reasonable name is fine by me.

> 

> Pedro>  #3 - The MI attribute is called "pac", and its content is

> Pedro>       literally " [PAC]".  I'd find that odd if I were a frontend author:

> Pedro>       the content is right aligned with a space, making doing anything with

> Pedro>       it other than appending it to the address text probably look odd,

> Pedro>       unless you bake in awareness of the attribute's text...  If I saw

> Pedro>       an attribute named "pac", I'd expect it to be a boolean?  At the

> Pedro>       least, the left space should not be part of the field, I think?

> 

> I think part of the pain here is an internal constraint, namely that the

> CLI ui-out wouldn't know to rewrite the boolean value to something else

> here.  But perhaps that's something that could just be addressed

> directly.


It looks like fixing the space just requires an additional call to uiout->text (" “).


How about I create a new field addr_flags? It would be a generic field into which
targets can add whichever fields they want to.

I then could add a call to a new function gdbarch_print_addr_flags() which prints the
PAC on AArch64 and nothing on all other targets?




Alan.
  
Pedro Alves Aug. 9, 2019, 2:17 p.m. UTC | #3
On 8/9/19 2:22 PM, Alan Hayward wrote:
> It looks like fixing the space just requires an additional call to uiout->text (" “).
> 
> 
> How about I create a new field addr_flags? It would be a generic field into which
> targets can add whichever fields they want to.
> 
> I then could add a call to a new function gdbarch_print_addr_flags() which prints the
> PAC on AArch64 and nothing on all other targets?

That sounds like two different things.  You could have the gdbarch method without
the uiout field.  Not sure what the uiout field buys you.  If CLI and MI are going to
print the same way, then it doesn't appear useful over field_string.  The gdbarch
method sounds fine.

Thanks,
Pedro Alves
  
Alan Hayward Aug. 9, 2019, 2:46 p.m. UTC | #4
> On 9 Aug 2019, at 15:17, Pedro Alves <palves@redhat.com> wrote:

> 

> On 8/9/19 2:22 PM, Alan Hayward wrote:

>> It looks like fixing the space just requires an additional call to uiout->text (" “).

>> 

>> 

>> How about I create a new field addr_flags? It would be a generic field into which

>> targets can add whichever fields they want to.

>> 

>> I then could add a call to a new function gdbarch_print_addr_flags() which prints the

>> PAC on AArch64 and nothing on all other targets?

> 

> That sounds like two different things.  You could have the gdbarch method without

> the uiout field.  Not sure what the uiout field buys you.  If CLI and MI are going to

> print the same way, then it doesn't appear useful over field_string.  The gdbarch

> method sounds fine.

> 


I was thinking of the following:

char *flags = gdbarch_print_pc_addr_flags(frame, pc);  /* Returns null or “PAC” or “FOO,BAR” etc */
if (flags)
{
  uiout->text (“ [“);
  uiout->field_string (“addr_flags", flags);
  uiout->text (“]“);
}

addr_flags can be printed by any target that wishes. And PAC only needs to be in
AArch64 specifics.



Alan.
  
Pedro Alves Aug. 9, 2019, 4:51 p.m. UTC | #5
On 8/9/19 3:46 PM, Alan Hayward wrote:

> I was thinking of the following:

Ah, I thought you meant create a "uiout->field_addr_flags(...);" method.

> 
> char *flags = gdbarch_print_pc_addr_flags(frame, pc);  /* Returns null or “PAC” or “FOO,BAR” etc */
> if (flags)
> {
>   uiout->text (“ [“);
>   uiout->field_string (“addr_flags", flags);
>   uiout->text (“]“);
> }
> 
> addr_flags can be printed by any target that wishes. And PAC only needs to be in
> AArch64 specifics.
Sounds fine to me.

Maybe return a std::string instead of a pointer to a static buffer.

Thanks,
Pedro Alves
  

Patch

diff --git a/gdb/doc/gdb.texinfo b/gdb/doc/gdb.texinfo
index 7f8c0aff1c..c8ca757989 100644
--- a/gdb/doc/gdb.texinfo
+++ b/gdb/doc/gdb.texinfo
@@ -24395,7 +24395,7 @@  target process.

 When @value{GDBN} is debugging the AArch64 architecture, and the program is
 using the v8.3-A feature Pointer Authentication (PAC), then whenever the link
-register @code{$lr} is pointing to an PAC function it's value will be masked.
+register @code{$lr} is pointing to an PAC function its value will be masked.
 When GDB prints a backtrace, any addresses that required unmasking will be
 postfixed with the marker [PAC].

diff --git a/gdb/stack.c b/gdb/stack.c
index 0859815baf..c599caf51c 100644
--- a/gdb/stack.c
+++ b/gdb/stack.c
@@ -1301,7 +1301,7 @@  print_frame (const frame_print_options &fp_opts,
            {
              uiout->field_core_addr ("addr", gdbarch, pc);
              if (get_frame_pc_masked (frame))
-               uiout->field_string ("pac", " [PAC]");
+               uiout->field_string ("addr", " [PAC]");
            }
          else
            uiout->field_string ("addr", "<unavailable>",