libgloss: i960: delete dead/broken code

Message ID 20231227015544.3747-1-vapier@gentoo.org
State New
Headers
Series libgloss: i960: delete dead/broken code |

Commit Message

Mike Frysinger Dec. 27, 2023, 1:55 a.m. UTC
  The i960 port has a lot of references to sim files that have never been
included in the tree afaict, and thus has never worked.  Delete all the
code to simplify.
---
 libgloss/i960/Makefile.in | 37 -------------------------------------
 1 file changed, 37 deletions(-)
  

Patch

diff --git a/libgloss/i960/Makefile.in b/libgloss/i960/Makefile.in
index bf1a49e581f9..0d1b80029e88 100644
--- a/libgloss/i960/Makefile.in
+++ b/libgloss/i960/Makefile.in
@@ -49,22 +49,12 @@  OBJS		= putnum.o unlink.o
 CFLAGS		= -g
 SCRIPTS		= 
 
-# Here is all of the simulator stuff
-SIM_SCRIPTS	=
-SIM_LDFLAGS	=
-SIM_BSP		= libsim.a
-SIM_CRT0	= sim-crt0.o
-SIM_OBJS	= sim-print.o sim-inbyte.o sim-sbrk.o sim-abort.o sim-errno.o simulator.o
-SIM_TEST	= sim-test
-SIM_INSTALL	= install-sim
-
 # Here is all of the mon960 stuff
 MON_LDFLAGS	=
 MON_BSP		= libmon960.a
 MON_CRT0	= crt0.o
 MON_OBJS	= mon-read.o mon-write.o mon-syscalls.o mon960.o
 MON_SCRIPTS	= mon960.ld
-MON_TEST	=
 MON_INSTALL	= install-mon
 
 # Host specific makefile fragment comes in here.
@@ -79,39 +69,16 @@  all: ${MON_CRT0} ${MON_BSP}
 #
 # here's where we build the board support packages for each target
 #
-${SIM_BSP}: ${OBJS} ${SIM_OBJS}
-	${AR} ${ARFLAGS} ${SIM_BSP} ${SIM_OBJS} ${OBJS}
-	${RANLIB} ${SIM_BSP}
-
 ${MON_BSP}: ${OBJS} ${MON_OBJS}
 	${AR} ${ARFLAGS} ${MON_BSP} ${MON_OBJS} ${OBJS}
 	${RANLIB} ${MON_BSP}
 
-#
-# here's where we build the test programs for each target
-#
-.PHONY: test
-test:	${SIM_TEST} ${MVME_TEST} ${EVM_TEST} 
-
-sim-test:	sim-test.x sim-test.dis
-
-sim-test.x:	test.o ${SIM_CRT0} ${SIM_BSP}
-	${CC} ${LDFLAGS_FOR_TARGET} -L${objdir} \
-	${SIM_CRT0} test.o \
-	-o sim-test.x ${LIBS_FOR_TARGET} -lc ${SIM_BSP}
-
-sim-test.dis:	sim-test.x
-	${OBJDUMP} -d sim-test.x > sim-test.dis
-
-
 #
 #
 #
 .c.S:
 	${CC} ${CFLAGS_FOR_TARGET} -c $<
 
-simulator.o: simulator.S
-sim-crt0.o: sim-crt0.S
 mvme-crt0.o: mvme-crt0.S
 mvme-exit.o: mvme-exit.S
 mvme-inbyte.o: mvme-inbyte.S
@@ -131,10 +98,6 @@  install-mon:
 	set -e; for x in ${MON_CRT0} ${MON_BSP}; do ${INSTALL_DATA} $$x $(DESTDIR)${tooldir}/lib${MULTISUBDIR}/$$x; done
 	set -e; for x in ${MON_SCRIPTS}; do ${INSTALL_DATA} ${srcdir}/$$x $(DESTDIR)${tooldir}/lib${MULTISUBDIR}/$$x; done
 
-install-sim:
-	${mkinstalldirs} ${DESTDIR}${tooldir}/lib
-	set -e; for x in ${SIM_CRT0} ${SIM_BSP} ${SIM_SCRIPTS}; do ${INSTALL_DATA} $$x $(DESTDIR)${tooldir}/lib/$$x; done
-
 doc:
 info:
 install-info: