diff mbox

[2/2] gnu: Update python2-qrcode

Message ID a01f95de1992711beb98338143c528db@d4n1.org
State New
Headers show

Commit Message

Daniel Pimentel June 17, 2016, 11:40 p.m. UTC
> * gnu/packages/python.scm (python2-qrcode): New variable.

done

> I think Andreas' comment still applies here i.e. better to use 
> 'pypi-url'.

done

> Can we make this a native-input ?

done

> This should be bsd-3 I think.

done

Thanks for your comments.

I
diff mbox

Patch

From 168d071bfc7a2e15f51ec0d8b5fe3f458cce69a8 Mon Sep 17 00:00:00 2001
From: Daniel Pimentel <d4n1@d4n1.org>
Date: Fri, 17 Jun 2016 20:31:51 -0300
Subject: [PATCH 4/4] Add python2-qrcode * gnu/packages/python.scm
 (python2-qrcode): New variable.

---
 gnu/packages/python.scm | 19 +++++++++----------
 1 file changed, 9 insertions(+), 10 deletions(-)

diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index db65ffc..dc98306 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -9273,25 +9273,24 @@  PBKDF2, specified in RSA PKCS#5 v2.0.")
 (define-public python2-qrcode
   (package
     (name "python2-qrcode")
-    (version "5.1")
+    (version "5.3")
     (source (origin
               (method url-fetch)
-              (uri (string-append
-                    "https://pypi.python.org/packages/source/q/qrcode/qrcode-"
-                    version ".tar.gz"))
+              (uri (pypi-uri "qrcode" version))
               (sha256
                (base32
                 "0skzrvhjnnacrz52jml4i050vdx5lfcd3np172srxjaghdgfxg9k"))))
     (build-system python-build-system)
     (inputs
-     `(("python2-setuptools" ,python2-setuptools)
-       ("python2-pillow" ,python2-pillow)
-       ("python2-six" ,python2-six)))    
+     `(("python2-pillow" ,python2-pillow)
+       ("python2-six" ,python2-six)))
+    (native-inputs
+     `(("python2-setuptools" ,python2-setuptools)))
     (arguments
-     `(#:python ,python-2)) ; only Python 2.7 is supported
+     `(#:python ,python-2))
     (home-page "https://pypi.python.org/pypi/qrcode")
     (synopsis "Python library to generate QR Codes")
     (description
      "Python library that uses image libraries, Python Imaging Library (PIL) 
-by default, to generate QR Codes.")
-    (license license:expat)))
+by default or Pillow, to generate QR Codes.")
+    (license bsd-3)))
-- 
2.7.4