diff mbox

gnu: gnunet-gtk: Add libunique support in gnunet-gtk.

Message ID 87twec8k4t.fsf@we.make.ritual.n0.is
State New
Headers show

Commit Message

non such Aug. 22, 2016, 11:21 p.m. UTC
In the commit message, is the ending "in gnunet-gtk" unnecessary? It
almost feels like it.
Thanks for merging the libunique patch.

Comments

Leo Famulari Aug. 23, 2016, 1:30 a.m. UTC | #1
On Mon, Aug 22, 2016 at 11:21:54PM +0000, ng0 wrote:
> In the commit message, is the ending "in gnunet-gtk" unnecessary? It
> almost feels like it.

Yes, I think it's unnecessary, so I removed it.

> Subject: [PATCH] gnu: gnunet-gtk: Add libunique support in gnunet-gtk.
> 
> * gnu/packages/gnunet.scm (gnunet-gtk)[inputs]: Add libunique.
> [arguments]: Add "--with-libunique" to #:configure-flags.

Thanks, pushed as d8bc4729f8!
diff mbox

Patch

From 71c7fa15df9793827e93823eb37c35b4357626cc Mon Sep 17 00:00:00 2001
From: ng0 <ng0@we.make.ritual.n0.is>
Date: Mon, 22 Aug 2016 23:13:03 +0000
Subject: [PATCH] gnu: gnunet-gtk: Add libunique support in gnunet-gtk.

* gnu/packages/gnunet.scm (gnunet-gtk)[inputs]: Add libunique.
[arguments]: Add "--with-libunique" to #:configure-flags.
---
 gnu/packages/gnunet.scm | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/gnunet.scm b/gnu/packages/gnunet.scm
index 7887322..b08ba74 100644
--- a/gnu/packages/gnunet.scm
+++ b/gnu/packages/gnunet.scm
@@ -325,7 +325,7 @@  services.")
                 "1p38k1s6a2fmcfc9a7cf1zrdycm9h06kqdyand4s3k500nj6mb4g"))))
     (arguments
      `(#:configure-flags
-       (list "--without-libunique"
+       (list "--with-libunique"
              "--with-qrencode"
              (string-append "--with-gnunet="
                             (assoc-ref %build-inputs "gnunet")))))
@@ -335,7 +335,8 @@  services.")
        ("gtk+" ,gtk+)
        ("libextractor" ,libextractor)
        ("glade3" ,glade3)
-       ("qrencode" ,qrencode)))
+       ("qrencode" ,qrencode)
+       ("libunique" ,libunique)))
     (native-inputs
      `(("pkg-config" ,pkg-config)
        ("libglade" ,libglade)))
-- 
2.9.3