diff mbox

[3/3] gnu: vlc: Add inputs.

Message ID 87pon8zdyl.fsf@gmail.com
State New
Headers show

Commit Message

Alex Vong Oct. 10, 2016, 10:38 a.m. UTC
Hello,

Thanks for the review. I check on hydra just now and indeed some inputs
does not build on all supported architectures, namely fluidsynth,
gst-plugins-base, libmpeg2 and samba. So I comment them out (in case
they are available in the future). Here is the new patch:
Cheers,
Alex

Leo Famulari <leo@famulari.name> writes:

> On Sat, Sep 10, 2016 at 11:08:18AM +0800, Alex Vong wrote:
>> From b9e30604e432586c89c5e33b27ba609852efd399 Mon Sep 17 00:00:00 2001
>> From: Alex Vong <alexvong1995@gmail.com>
>> Date: Tue, 30 Aug 2016 02:30:57 +0800
>> Subject: [PATCH 3/3] gnu: vlc: Add inputs.
>> 
>> * gnu/packages/video.scm (vlc)[inputs]: Add eudev, faad2, fluidsynth,
>>   gnome-vfs, gst-plugins-base, gtk+-2, jack-2, libass, libavc1394,
>>   libbluray, libcaca, libdca, libdvdnav, libdvdread, libmpeg2,
>>   libmodplug, libmtp, libnotify, libraw1394, libshout, librsvg, libupnp,
>>   libva, libvdpau, samba, taglib, twolame.
>
> My question is similar to the one for the last patch. Can you check on
> <https://hydra.gnu.org> if these packages build for all our supported
> architectures? If so, okay for me.
diff mbox

Patch

From f73bc602a3c14cb7563df731b18b506423e27046 Mon Sep 17 00:00:00 2001
From: Alex Vong <alexvong1995@gmail.com>
Date: Tue, 30 Aug 2016 02:30:57 +0800
Subject: [PATCH] gnu: vlc: Add inputs.

* gnu/packages/video.scm (vlc)[inputs]: Add eudev, faad2, gtk+-2,
  jack-1, libass, libavc1394, libbluray, libcaca, libdca, libdvdnav,
  libdvdread, libmodplug, libmtp, libnotify, libraw1394, libshout,
  librsvg, libupnp, libva, libvdpau, taglib, twolame.
---
 gnu/packages/video.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)

diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 5e1bdf1..75a4f60 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -63,9 +63,12 @@ 
   #:use-module (gnu packages gl)
   #:use-module (gnu packages glib)
   #:use-module (gnu packages guile)
+  #:use-module (gnu packages gnome)
   #:use-module (gnu packages gnupg)
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages image)
+  #:use-module (gnu packages libupnp)
+  #:use-module (gnu packages libusb)
   #:use-module (gnu packages linux)
   #:use-module (gnu packages lua)
   #:use-module (gnu packages mp3)
@@ -614,20 +617,44 @@  audio/video codec library.")
      `(("alsa-lib" ,alsa-lib)
        ("avahi" ,avahi)
        ("dbus" ,dbus)
+       ("eudev" ,eudev)
+       ("faad2" ,faad2)
        ("flac" ,flac)
        ("ffmpeg" ,ffmpeg-2.8)               ;fails to build against ffmpeg 3.0
+       ;; ("fluidsynth" ,fluidsynth) ; unavailable on armhf
        ("fontconfig" ,fontconfig)
        ("freetype" ,freetype)
+       ;; ("gnome-vfs" ,gnome-vfs) ; cannot be detected by configure
        ("gnutls" ,gnutls)
+       ;;("gst-plugins-base" ,gst-plugins-base) ;unavailable on armhf, mips64el
+       ("gtk+" ,gtk+-2)
+       ("jack" ,jack-1)
        ("liba52" ,liba52)
+       ("libass" ,libass)
+       ("libavc1394" ,libavc1394)
+       ("libbluray" ,libbluray)
+       ("libcaca" ,libcaca)
+       ("libdca" ,libdca)
        ("libcddb" ,libcddb)
+       ("libdvdnav" ,libdvdnav)
+       ("libdvdread" ,libdvdread)
        ("libgcrypt" ,libgcrypt)
        ("libkate" ,libkate)
        ("libmad" ,libmad)
+       ;; ("libmpeg2" ,libmpeg2) ; unavailable on armhf, mips64el
+       ("libmodplug" ,libmodplug)
+       ("libmtp" ,libmtp)
+       ("libnotify" ,libnotify)
        ("libogg" ,libogg)
        ("libpng" ,libpng)
+       ("libraw1394" ,libraw1394)
        ("libsamplerate" ,libsamplerate)
+       ("libshout" ,libshout)
        ("libssh2" ,libssh2)
+       ("librsvg" ,librsvg)
+       ("libupnp" ,libupnp)
+       ("libva" ,libva)
+       ("libvdpau" ,libvdpau)
        ("libvorbis" ,libvorbis)
        ("libtheora" ,libtheora)
        ("libxext" ,libxext)
@@ -644,9 +671,12 @@  audio/video codec library.")
        ("qt" ,qt) ; FIXME: reenable modular qt after update - requires building
        ;("qtbase" ,qtbase) with -std=gnu++11.
        ;("qtx11extras" ,qtx11extras)
+       ;; ("samba" ,samba) ; unavailable on mips64el
        ("sdl" ,sdl)
        ("sdl-image" ,sdl-image)
        ("speex" ,speex)
+       ("taglib" ,taglib)
+       ("twolame" ,twolame)
        ("xcb-util-keysyms" ,xcb-util-keysyms)))
     (arguments
      `(#:configure-flags
-- 
2.10.1