diff mbox

gnu: Add python-pypump

Message ID 20160905092104.GA23794@macbook42.flashner.co.il
State New
Headers show

Commit Message

Efraim Flashner Sept. 5, 2016, 9:21 a.m. UTC
On Fri, Aug 19, 2016 at 06:17:47PM -0400, Leo Famulari wrote:
> On Mon, Aug 15, 2016 at 03:17:57PM -0700, Dylan Jeffers wrote:
> > On Mon, 15 Aug 2016 14:41:28 -0400
> > Leo Famulari <leo@famulari.name> wrote:
> > 
> > > On Sun, Aug 14, 2016 at 04:07:11PM -0700, Dylan Jeffers wrote:
> > > > > The latest upstream version 0.7. Is there a reason not to use the
> > > > > latest version in this case?  
> > > > 
> > > > For my immediate purposes, I need pypump 0.6, since thats the
> > > > version used in my projects. Since the versions are quite
> > > > different, maybe we include both of them?  
> > > 
> > > I think we should package the latest version, at least.
> > > 
> > > Maybe we could also package 0.6 with a package 'python-pypump-0.6'
> > > that inherits from python-pypump. Or, you could keep that inherited
> > > python-pypump-0.6 in a private package repo, and use
> > > GUIX_PACKAGE_PATH.
> > > 
> > > I'd prefer the latter option. I don't think we have a precedent of
> > > adding old releases, although we do sometimes keep them around for
> > > compatibility. But I could be mistaken.
> > > 
> > > What do people think we should do?
> > 
> > Yes I agree with the second alternative as well.
> 
> Okay, will you send a patch for it?
> 

I tried to apply the original patch but it failed. Can you send an
updated patch set? I've also included the pypump-0.7 patch that I wrote.
I have no real way to test it, but maybe you do.
diff mbox

Patch

diff --git a/gnu/packages/pumpio.scm b/gnu/packages/pumpio.scm
index a74d474..f834884 100644
--- a/gnu/packages/pumpio.scm
+++ b/gnu/packages/pumpio.scm
@@ -23,7 +23,9 @@ 
   #:use-module (guix download)
   #:use-module (guix git-download)
   #:use-module (guix build-system gnu)
+  #:use-module (guix build-system python)
   #:use-module (gnu packages aspell)
+  #:use-module (gnu packages python)
   #:use-module (gnu packages qt)
   #:use-module (gnu packages web))
 
@@ -66,3 +68,40 @@ 
     (description "Pumpa is a simple pump.io client written in C++ and Qt.")
     (home-page "https://pumpa.branchable.com/")
     (license gpl3+)))
+
+(define-public python-pypump
+  (package
+    (name "python-pypump")
+    (version "0.7")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "PyPump" version))
+        (sha256
+         (base32
+          "0100b8r76hwh4lbiwb2dji6jccpi4hgi2ns7qdgb3lwfidnya3ha"))))
+    (build-system python-build-system)
+    (arguments `(#:tests? #f)) ; FIXME: can't find test directory.
+    (inputs
+     `(("python-dateutil-2" ,python-dateutil-2)
+       ("python-requests" ,python-requests)
+       ("python-requests-oauthlib" ,python-requests-oauthlib)))
+    (home-page "https://github.com/xray7224/PyPump")
+    (synopsis "Python Pump.io library")
+    (description "Python Pump.io library")
+    (license gpl3+)
+    (properties `((python2-variant . ,(delay python2-pypump))))))
+
+(define-public python2-pypump
+  (let ((pypump (package-with-python2
+                  (strip-python2-variant python-pypump))))
+    (package (inherit pypump)
+      (inputs
+       `(("python2-ndg-httpsclient" ,python2-ndg-httpsclient)
+         ("python2-pyasn1" ,python2-pyasn1)
+         ("python2-pyopenssl" ,python2-pyopenssl)
+         ,@(package-inputs pypump)))
+      (native-inputs
+       `(("python2-mock" ,python2-mock)
+         ("python2-setuptools" ,python2-setuptools)
+         ,@(package-native-inputs pypump))))))