diff mbox

[12/13] gnu: avidemux: Fix regression caused by update to qt 5.7.

Message ID 20160821140825.13048-12-david@craven.ch
State New
Headers show

Commit Message

David Craven Aug. 21, 2016, 2:08 p.m. UTC
* gnu/packages/video.scm (avidemux)[inputs]: Use qt 5.6.1-1.
---
 gnu/packages/video.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Mark H Weaver Aug. 21, 2016, 8:13 p.m. UTC | #1
David Craven <david@craven.ch> writes:

> * gnu/packages/video.scm (avidemux)[inputs]: Use qt 5.6.1-1.

In the summary line and in the line above, how about writing
"Use monolithic Qt 5.6."?

> ---
>  gnu/packages/video.scm | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
> index 45f8a28..7c68be8 100644
> --- a/gnu/packages/video.scm
> +++ b/gnu/packages/video.scm
> @@ -1144,8 +1144,8 @@ for use with HTML5 video.")
>         ("perl" ,perl)
>         ("pulseaudio" ,pulseaudio)
>         ("python" ,python-wrapper)
> -       ("qtbase" ,qtbase)
> -       ("qttools" ,qttools)
> +       ("qtbase" ,qt)
> +       ;("qttools" ,qttools)

Please change "qtbase" => "qt" and add a FIXME comment reminding us to
get this working with modular Qt 5.7+.

What do you think?

      Mark
David Craven Aug. 21, 2016, 9:08 p.m. UTC | #2
The problem isn't with qt, when adding -std=gnu++11 the build fails.
And I'm not really a C/C++ developer, so sometimes the error messages
look a little intimidating. But yes I'll make the changes...
diff mbox

Patch

diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 45f8a28..7c68be8 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1144,8 +1144,8 @@  for use with HTML5 video.")
        ("perl" ,perl)
        ("pulseaudio" ,pulseaudio)
        ("python" ,python-wrapper)
-       ("qtbase" ,qtbase)
-       ("qttools" ,qttools)
+       ("qtbase" ,qt)
+       ;("qttools" ,qttools)
        ("sdl" ,sdl)
        ("sqlite" ,sqlite)
        ("yasm" ,yasm)