diff mbox

[10/13] gnu: v4l-utils: Fix regression caused by update to qt 5.7.

Message ID 20160821140825.13048-10-david@craven.ch
State New
Headers show

Commit Message

David Craven Aug. 21, 2016, 2:08 p.m. UTC
* gnu/packages/video.scm (v4l-utils)[arguments]: Require gnu++11.
---
 gnu/packages/video.scm | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

Mark H Weaver Aug. 21, 2016, 8:04 p.m. UTC | #1
David Craven <david@craven.ch> writes:

> * gnu/packages/video.scm (v4l-utils)[arguments]: Require gnu++11.
> ---
>  gnu/packages/video.scm | 3 ++-
>  1 file changed, 2 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
> index bc6415e..28e49b3 100644
> --- a/gnu/packages/video.scm
> +++ b/gnu/packages/video.scm
> @@ -1396,7 +1396,8 @@ tools, XML authoring components, and an extensible plug-in based API.")
>       '(#:configure-flags
>         (list (string-append "--with-udevdir="
>                              (assoc-ref %outputs "out")
> -                            "/lib/udev"))))
> +                            "/lib/udev")
> +              "CXXFLAGS=-std=gnu++11")))

The " should be lined up under the "(", so that last line should be
moved one column to the left.

Also, although I neglected to mention it, in general when the change
made is simple enough to describe in the summary line, better to do
that, so instead of writing "Fix regression caused by update to qt 5.7",
please write "Require gnu++11.".

Otherwise looks good to me.

     Thanks,
       Mark
diff mbox

Patch

diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index bc6415e..28e49b3 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1396,7 +1396,8 @@  tools, XML authoring components, and an extensible plug-in based API.")
      '(#:configure-flags
        (list (string-append "--with-udevdir="
                             (assoc-ref %outputs "out")
-                            "/lib/udev"))))
+                            "/lib/udev")
+              "CXXFLAGS=-std=gnu++11")))
     (native-inputs
      `(("pkg-config" ,pkg-config)))
     (inputs