diff mbox

gnu: libgcrypt update to 1.7.1

Message ID 20160617224446.GA9320@khazad-dum
State New
Headers show

Commit Message

non such June 17, 2016, 10:44 p.m. UTC
On 2016-06-17(03:28:36-0400), Leo Famulari wrote:
> On Fri, Jun 17, 2016 at 06:59:23PM +0000, ng0 wrote:
> > On 2016-06-17(01:43:02-0400), Leo Famulari wrote:
> > > On Fri, Jun 17, 2016 at 05:02:44PM +0200, Ludovic Courtès wrote:
> > > > Efraim Flashner <efraim@flashner.co.il> skribis:
> > > >
> > > > > On Thu, Jun 16, 2016 at 11:40:47AM -0400, Leo Famulari wrote:
> > > > >> On Wed, Jun 15, 2016 at 07:53:28PM +0000, ng0 wrote:
> > > > >> > * gnu/packages/gnupg.scm (libgcrypt):  Update to 1.7.1
> > > > >>
> > > > >> This looks good to me. What branch should it go on?
> > > > >>
> > > > >
> > > > > either core-updates or core-updates-next
> > > >
> > > > The latter please.  :-)
> > >
> > > Okay, in that case, can you rebase it on core-updates, ng0? Otherwise is
> > > won't apply cleanly due to trying to upgrade from 1.6.5 instad of 1.7.0.
> > >
> >
> > This should be relatively easy when I have the gnupg branch still around,
> > otherwise I'll recreate it.
> >
> > With the wording familiar to me yet sometimes not good to comprehend even
> > when I hear and parse it correctly when talking:
> > I should rebase the commit on the branch
> > `core-updates` which currently is at version 1.6.5?
>
> I think your copy of core-updates needs to be updated. I pushed your
> patch "gnu: libgcrypt: Update to 1.7.0" as 81068f178 to it in April ;)
>
> All you need to do is get the latest core-updates, and then re-do this
> patch on that branch, so that it updates from 1.7.0 instead of 1.6.5.
> You don't need to do anything with gnupg.

That was the name of the branch where I worked on gnupg.scm, that's why.

inlined and appened the rebase on core-updates (I left out the header as
this was already added with the gnupg update):

From 372943f91376905ebefe47372cdf55e1c14bc165 Mon Sep 17 00:00:00 2001
From: ng0 <ng0@we.make.ritual.n0.is>
Date: Fri, 17 Jun 2016 22:35:18 +0000
Subject: [PATCH] gnu: libgcrypt: Update to 1.7.1.

* gnu/packages/gnupg.scm (libgcrypt): Update to 1.7.1.
---
 gnu/packages/gnupg.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

--
2.8.4



It's the very same, so I did not check it, build functionality shold be
exactly the same as in master, given that the last commit is a merge of
master.


--
♥Ⓐ ng0
For non-prism friendly talk find me on
psyced.org / loupsycedyglgamf.onion
diff mbox

Patch

From 372943f91376905ebefe47372cdf55e1c14bc165 Mon Sep 17 00:00:00 2001
From: ng0 <ng0@we.make.ritual.n0.is>
Date: Fri, 17 Jun 2016 22:35:18 +0000
Subject: [PATCH] gnu: libgcrypt: Update to 1.7.1.

* gnu/packages/gnupg.scm (libgcrypt): Update to 1.7.1.
---
 gnu/packages/gnupg.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index 2ef2410..f2b53c2 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -74,14 +74,14 @@  Daemon and possibly more in the future.")
 (define-public libgcrypt
   (package
     (name "libgcrypt")
-    (version "1.7.0")
+    (version "1.7.1")
     (source (origin
              (method url-fetch)
              (uri (string-append "mirror://gnupg/libgcrypt/libgcrypt-"
                                  version ".tar.bz2"))
              (sha256
               (base32
-               "14pspxwrqcgfklw3dgmywbxqwdzcym7fznfrqh9rk4vl8jkpxrmh"))))
+               "15bsdpihb8xvr2a6sh0ikzw9wdw3gdi4pl1vpr6wc48npzy9q3a5"))))
     (build-system gnu-build-system)
     (propagated-inputs
      `(("libgpg-error-host" ,libgpg-error)))
-- 
2.8.4