diff mbox

gnu: libgcrypt update to 1.7.1

Message ID 20160615195328.GA13352@khazad-dum
State New
Headers show

Commit Message

non such June 15, 2016, 7:53 p.m. UTC
output of test: https://ptpb.pw/k6oU

From 422b2a632b94be9ea57130d7d231d95912dac253 Mon Sep 17 00:00:00 2001
From: ng0 <ng0@we.make.ritual.n0.is>
Date: Wed, 15 Jun 2016 19:41:52 +0000
Subject: [PATCH] gnu: libgcrypt: Update to 1.7.1.

* gnu/packages/gnupg.scm (libgcrypt):  Update to 1.7.1
---
 gnu/packages/gnupg.scm | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

--
2.8.4


--
♥Ⓐ ng0
For non-prism friendly talk find me on
psyced.org / loupsycedyglgamf.onion

Comments

Leo Famulari June 16, 2016, 3:40 p.m. UTC | #1
On Wed, Jun 15, 2016 at 07:53:28PM +0000, ng0 wrote:
> * gnu/packages/gnupg.scm (libgcrypt):  Update to 1.7.1

This looks good to me. What branch should it go on?
Efraim Flashner June 16, 2016, 4:28 p.m. UTC | #2
On Thu, Jun 16, 2016 at 11:40:47AM -0400, Leo Famulari wrote:
> On Wed, Jun 15, 2016 at 07:53:28PM +0000, ng0 wrote:
> > * gnu/packages/gnupg.scm (libgcrypt):  Update to 1.7.1
> 
> This looks good to me. What branch should it go on?
> 

either core-updates or core-updates-next
Ludovic Courtès June 17, 2016, 3:02 p.m. UTC | #3
Efraim Flashner <efraim@flashner.co.il> skribis:

> On Thu, Jun 16, 2016 at 11:40:47AM -0400, Leo Famulari wrote:
>> On Wed, Jun 15, 2016 at 07:53:28PM +0000, ng0 wrote:
>> > * gnu/packages/gnupg.scm (libgcrypt):  Update to 1.7.1
>> 
>> This looks good to me. What branch should it go on?
>> 
>
> either core-updates or core-updates-next

The latter please.  :-)

Ludo’.
Leo Famulari June 17, 2016, 5:43 p.m. UTC | #4
On Fri, Jun 17, 2016 at 05:02:44PM +0200, Ludovic Courtès wrote:
> Efraim Flashner <efraim@flashner.co.il> skribis:
> 
> > On Thu, Jun 16, 2016 at 11:40:47AM -0400, Leo Famulari wrote:
> >> On Wed, Jun 15, 2016 at 07:53:28PM +0000, ng0 wrote:
> >> > * gnu/packages/gnupg.scm (libgcrypt):  Update to 1.7.1
> >> 
> >> This looks good to me. What branch should it go on?
> >> 
> >
> > either core-updates or core-updates-next
> 
> The latter please.  :-)

Okay, in that case, can you rebase it on core-updates, ng0? Otherwise is
won't apply cleanly due to trying to upgrade from 1.6.5 instad of 1.7.0.
non such June 17, 2016, 6:59 p.m. UTC | #5
On 2016-06-17(01:43:02-0400), Leo Famulari wrote:
> On Fri, Jun 17, 2016 at 05:02:44PM +0200, Ludovic Courtès wrote:
> > Efraim Flashner <efraim@flashner.co.il> skribis:
> >
> > > On Thu, Jun 16, 2016 at 11:40:47AM -0400, Leo Famulari wrote:
> > >> On Wed, Jun 15, 2016 at 07:53:28PM +0000, ng0 wrote:
> > >> > * gnu/packages/gnupg.scm (libgcrypt):  Update to 1.7.1
> > >>
> > >> This looks good to me. What branch should it go on?
> > >>
> > >
> > > either core-updates or core-updates-next
> >
> > The latter please.  :-)
>
> Okay, in that case, can you rebase it on core-updates, ng0? Otherwise is
> won't apply cleanly due to trying to upgrade from 1.6.5 instad of 1.7.0.
>

This should be relatively easy when I have the gnupg branch still around,
otherwise I'll recreate it.

With the wording familiar to me yet sometimes not good to comprehend even
when I hear and parse it correctly when talking:
I should rebase the commit on the branch
`core-updates` which currently is at version 1.6.5?

--
♥Ⓐ ng0
For non-prism friendly talk find me on
psyced.org / loupsycedyglgamf.onion
Leo Famulari June 17, 2016, 7:28 p.m. UTC | #6
On Fri, Jun 17, 2016 at 06:59:23PM +0000, ng0 wrote:
> On 2016-06-17(01:43:02-0400), Leo Famulari wrote:
> > On Fri, Jun 17, 2016 at 05:02:44PM +0200, Ludovic Courtès wrote:
> > > Efraim Flashner <efraim@flashner.co.il> skribis:
> > >
> > > > On Thu, Jun 16, 2016 at 11:40:47AM -0400, Leo Famulari wrote:
> > > >> On Wed, Jun 15, 2016 at 07:53:28PM +0000, ng0 wrote:
> > > >> > * gnu/packages/gnupg.scm (libgcrypt):  Update to 1.7.1
> > > >>
> > > >> This looks good to me. What branch should it go on?
> > > >>
> > > >
> > > > either core-updates or core-updates-next
> > >
> > > The latter please.  :-)
> >
> > Okay, in that case, can you rebase it on core-updates, ng0? Otherwise is
> > won't apply cleanly due to trying to upgrade from 1.6.5 instad of 1.7.0.
> >
> 
> This should be relatively easy when I have the gnupg branch still around,
> otherwise I'll recreate it.
> 
> With the wording familiar to me yet sometimes not good to comprehend even
> when I hear and parse it correctly when talking:
> I should rebase the commit on the branch
> `core-updates` which currently is at version 1.6.5?

I think your copy of core-updates needs to be updated. I pushed your
patch "gnu: libgcrypt: Update to 1.7.0" as 81068f178 to it in April ;)

All you need to do is get the latest core-updates, and then re-do this
patch on that branch, so that it updates from 1.7.0 instead of 1.6.5.
You don't need to do anything with gnupg.
diff mbox

Patch

From 422b2a632b94be9ea57130d7d231d95912dac253 Mon Sep 17 00:00:00 2001
From: ng0 <ng0@we.make.ritual.n0.is>
Date: Wed, 15 Jun 2016 19:41:52 +0000
Subject: [PATCH] gnu: libgcrypt: Update to 1.7.1.

* gnu/packages/gnupg.scm (libgcrypt):  Update to 1.7.1
---
 gnu/packages/gnupg.scm | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index c5055b6..eb2dc80 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -6,6 +6,7 @@ 
 ;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
 ;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2016 Christopher Allan Webber <cwebber@dustycloud.org>
+;;; Copyright © 2016 ng0 <ng0@we.make.ritual.n0.is>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -73,14 +74,14 @@  Daemon and possibly more in the future.")
 (define-public libgcrypt
   (package
     (name "libgcrypt")
-    (version "1.6.5")
+    (version "1.7.1")
     (source (origin
              (method url-fetch)
              (uri (string-append "mirror://gnupg/libgcrypt/libgcrypt-"
                                  version ".tar.bz2"))
              (sha256
               (base32
-               "0959mwfzsxhallxdqlw359xg180ll2skxwyy35qawmfl89cbr7pl"))))
+               "15bsdpihb8xvr2a6sh0ikzw9wdw3gdi4pl1vpr6wc48npzy9q3a5"))))
     (build-system gnu-build-system)
     (propagated-inputs
      `(("libgpg-error-host" ,libgpg-error)))
-- 
2.8.4