mbox series

[0/5] getaddrinfo spaghetti cleanups

Message ID 20210803212919.3059194-1-siddhesh@sourceware.org
Headers show
Series getaddrinfo spaghetti cleanups | expand


Siddhesh Poyarekar Aug. 3, 2021, 9:29 p.m. UTC
This series cleans up a bunch of confusing gotos in various functions in
getaddrinfo.  The gotos jump from one condition to another and in
various directions, making code quite hard to read.

Siddhesh Poyarekar (5):
  gaiconf_init: Refactor some bits for readability
  gai_init: Avoid jumping from if condition to its else counterpart
  getaddrinfo: Refactor code for readability
  gaih_inet: Consolidate got_port code
  gaih_inet: Make process_list label into a function

 sysdeps/posix/getaddrinfo.c | 1067 ++++++++++++++++++-----------------
 1 file changed, 542 insertions(+), 525 deletions(-)