From patchwork Wed Sep 21 15:40:23 2016 Content-Type: text/plain; charset="utf-8" MIME-Version: 1.0 Content-Transfer-Encoding: 7bit X-Patchwork-Submitter: Yao Qi X-Patchwork-Id: 15847 Received: (qmail 79472 invoked by alias); 21 Sep 2016 15:40:45 -0000 Mailing-List: contact gdb-patches-help@sourceware.org; run by ezmlm Precedence: bulk List-Id: List-Unsubscribe: List-Subscribe: List-Archive: List-Post: List-Help: , Sender: gdb-patches-owner@sourceware.org Delivered-To: mailing list gdb-patches@sourceware.org Received: (qmail 79243 invoked by uid 89); 21 Sep 2016 15:40:44 -0000 Authentication-Results: sourceware.org; auth=none X-Virus-Found: No X-Spam-SWARE-Status: No, score=-1.5 required=5.0 tests=AWL, BAYES_00, FREEMAIL_FROM, RCVD_IN_DNSWL_NONE, RCVD_IN_SORBS_SPAM, SPF_PASS autolearn=no version=3.3.2 spammy=Hx-languages-length:987, 3587, 358, 7 X-HELO: mail-wm0-f66.google.com Received: from mail-wm0-f66.google.com (HELO mail-wm0-f66.google.com) (74.125.82.66) by sourceware.org (qpsmtpd/0.93/v0.84-503-g423c35a) with ESMTP; Wed, 21 Sep 2016 15:40:34 +0000 Received: by mail-wm0-f66.google.com with SMTP id b184so9290607wma.3 for ; Wed, 21 Sep 2016 08:40:33 -0700 (PDT) X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20130820; h=x-gm-message-state:from:to:subject:date:message-id; bh=RuuonYQJOVLJIKy+PHskMYsHOxO/Ewv8ifASAufs6sw=; b=E9YGergMpG00FL3ZE+1f6zzCfXQX3J/9nhHwQROZJ4OMJmz2JMTaxI+CZByApJYUgW 7Di94b2OCk1toFPtUFn4tXKeCMIuo2KGN7m/yWD7re8vyC0XBFdGEVVAdfQVWezt8ZCx eeP07bi3fw3c6P/FyIja18obpXylNmbu8qY9Yf354EoFiNIyfMQluq2kzBBGmm/lUDdu T+r19gL5X3uq19NWCv85yu58UUHrzpC9L7vGsGMVgEKSAPi62LPzU/8a3yJXeuUYLQS3 xeVonJ41iczeRiSsYxEgmB1tVjjIAGvwvTdXJfAPsLRHfJvfVhUf28dsD3r7n+h1s/fm jGag== X-Gm-Message-State: AE9vXwN0MltOkLMZtkuJb739Pz35zOMF/htlUSeq2+rwrWOwLJNNZ57Y6qeQe76BlgmPKQ== X-Received: by 10.194.90.239 with SMTP id bz15mr34521590wjb.146.1474472431786; Wed, 21 Sep 2016 08:40:31 -0700 (PDT) Received: from E107787-LIN.cambridge.arm.com ([86.65.39.12]) by smtp.gmail.com with ESMTPSA id 4sm32994092wmu.2.2016.09.21.08.40.31 for (version=TLS1_2 cipher=ECDHE-RSA-AES128-SHA bits=128/128); Wed, 21 Sep 2016 08:40:31 -0700 (PDT) From: Yao Qi X-Google-Original-From: Yao Qi To: gdb-patches@sourceware.org Subject: [PATCH] Check the right proc name Date: Wed, 21 Sep 2016 16:40:23 +0100 Message-Id: <1474472423-20278-1-git-send-email-yao.qi@linaro.org> X-IsSubscribed: yes In lib/gdbserver-support.exp, we rename gdb_exit to gdbserver_orig_gdb_exit, but we check the existence gdbserver_gdb_exit. We should check gdbserver_orig_gdb_exit instead. Looks it is a typo or an oversight. gdb/testsuite: 2016-09-21 Yao Qi * lib/gdbserver-support.exp: Check the existence of gdbserver_orig_gdb_exit rather than gdbserver_gdb_exit. --- gdb/testsuite/lib/gdbserver-support.exp | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/gdb/testsuite/lib/gdbserver-support.exp b/gdb/testsuite/lib/gdbserver-support.exp index c0f17cd..70c8a5f 100644 --- a/gdb/testsuite/lib/gdbserver-support.exp +++ b/gdb/testsuite/lib/gdbserver-support.exp @@ -358,7 +358,7 @@ proc close_gdbserver {} { # Hook into GDB exit, and close GDBserver. -if { [info procs gdbserver_gdb_exit] == "" } { +if { [info procs gdbserver_orig_gdb_exit] == "" } { rename gdb_exit gdbserver_orig_gdb_exit } proc gdb_exit {} {