sim: stop configuring common subdir [committed]

Message ID 1452329644-28449-1-git-send-email-vapier@gentoo.org
State Committed
Headers

Commit Message

Mike Frysinger Jan. 9, 2016, 8:54 a.m. UTC
  Now that cconfig.h doesn't exist, there's no need to build in the common
subdir anymore.  We leave the configure/Makefile files in there as there
is a helper for developers to generate the nltvals.def file.  Once that
gets cleaned up in the future though, we can drop the build logic too.
---
 sim/ChangeLog     |  7 +++++++
 sim/configure     | 10 ----------
 sim/configure.ac  |  3 ---
 sim/configure.tgt |  5 -----
 4 files changed, 7 insertions(+), 18 deletions(-)
  

Patch

diff --git a/sim/ChangeLog b/sim/ChangeLog
index 93a6ee7..30eee38 100644
--- a/sim/ChangeLog
+++ b/sim/ChangeLog
@@ -1,5 +1,12 @@ 
 2016-01-09  Mike Frysinger  <vapier@gentoo.org>
 
+	* configure.ac: Delete sim_common check and the
+	AC_CONFIG_SUBDIRS(common) call.
+	* configure: Regenerate.
+	* configure.tgt (sim_common): Delete the variable.
+
+2016-01-09  Mike Frysinger  <vapier@gentoo.org>
+
 	* .gitignore: Delete /common/cconfig.h entry.
 
 2016-01-05  Nick Clifton  <nickc@redhat.com>
diff --git a/sim/configure b/sim/configure
index 3447321..2729e69 100755
diff --git a/sim/configure.ac b/sim/configure.ac
index 39f9c6e..22db00f 100644
--- a/sim/configure.ac
+++ b/sim/configure.ac
@@ -43,9 +43,6 @@  m4_define([SIM_ARCH], [
 if test "${enable_sim}" != no; then
    sinclude(configure.tgt)
    AC_CONFIG_SUBDIRS(testsuite)
-   if test "$sim_common" = yes; then
-      AC_CONFIG_SUBDIRS(common)
-   fi
    if test "$sim_igen" = yes; then
       AC_CONFIG_SUBDIRS(igen)
    fi
diff --git a/sim/configure.tgt b/sim/configure.tgt
index 83f6cb2..c958fb3 100644
--- a/sim/configure.tgt
+++ b/sim/configure.tgt
@@ -11,7 +11,6 @@  dnl the shell level, so use sinclude(...) to pull it in.
 dnl glue to avoid code duplication at top level
 m4_ifndef([SIM_ARCH], [AC_DEFUN([SIM_ARCH],[sim_arch=$1])])
 
-sim_common=yes
 sim_igen=no
 sim_arch=
 case "${target}" in
@@ -102,9 +101,5 @@  case "${target}" in
        SIM_ARCH(v850)
        sim_igen=yes
        ;;
-   *)
-       # No simulator subdir, so the subdir "common" isn't needed.
-       sim_common=no
-       ;;
 esac
 AC_SUBST(sim_arch)