[3/4] sim: d10v: delete NEED_UI_LOOP_HOOK handling

Message ID 1427696554-17585-3-git-send-email-vapier@gentoo.org
State Committed
Headers

Commit Message

Mike Frysinger March 30, 2015, 6:22 a.m. UTC
  This hook is used only when linked into gdb, and d10v doesn't have a gdb
port anymore.  Punt it.

Committed.
---
 sim/d10v/ChangeLog   |  7 +++++++
 sim/d10v/Makefile.in |  3 +--
 sim/d10v/interp.c    | 19 -------------------
 3 files changed, 8 insertions(+), 21 deletions(-)
  

Patch

diff --git a/sim/d10v/ChangeLog b/sim/d10v/ChangeLog
index 08a099f..ca4b5d2 100644
--- a/sim/d10v/ChangeLog
+++ b/sim/d10v/ChangeLog
@@ -1,5 +1,12 @@ 
 2015-03-30  Mike Frysinger  <vapier@gentoo.org>
 
+	* Makefile.in (SIM_EXTRA_CFLAGS): Delete -DNEED_UI_LOOP_HOOK.
+	* interp.c [NEED_UI_LOOP_HOOK] (UI_LOOP_POLL_INTERVAL,
+	ui_loop_hook_counter, deprecated_ui_loop_hook): Delete.
+	(sim_resume) [NEED_UI_LOOP_HOOK]: Delete ui code.
+
+2015-03-30  Mike Frysinger  <vapier@gentoo.org>
+
 	* Makefile.in (gencode.o, d10v-opc.o): Add $(WARN_CFLAGS).
 	(gencode): Add $(BUILD_LDFLAGS).
 	* endian.c (get_word, get_longword, get_longlong, write_word,
diff --git a/sim/d10v/Makefile.in b/sim/d10v/Makefile.in
index 5ea5b1d..fb2d72d 100644
--- a/sim/d10v/Makefile.in
+++ b/sim/d10v/Makefile.in
@@ -22,8 +22,7 @@  SIM_RUN_OBJS = run.o
 
 SIM_OBJS = interp.o table.o simops.o endian.o sim-load.o
 SIM_EXTRA_CLEAN = clean-extra
-SIM_EXTRA_CFLAGS = -DNEED_UI_LOOP_HOOK -DSIM_HAVE_ENVIRONMENT \
-	-DSIM_USE_DEPRECATED_RUN_FRONTEND
+SIM_EXTRA_CFLAGS = -DSIM_HAVE_ENVIRONMENT -DSIM_USE_DEPRECATED_RUN_FRONTEND
 
 INCLUDE = d10v_sim.h $(srcroot)/include/gdb/callback.h targ-vals.h endian.c \
 	$(srcroot)/include/gdb/sim-d10v.h
diff --git a/sim/d10v/interp.c b/sim/d10v/interp.c
index 57bca39..0b21549 100644
--- a/sim/d10v/interp.c
+++ b/sim/d10v/interp.c
@@ -56,17 +56,6 @@  extern void sim_set_profile (int n);
 extern void sim_set_profile_size (int n);
 static INLINE uint8 *map_memory (unsigned phys_addr);
 
-#ifdef NEED_UI_LOOP_HOOK
-/* How often to run the ui_loop update, when in use */
-#define UI_LOOP_POLL_INTERVAL 0x14000
-
-/* Counter for the ui_loop_hook update */
-static long ui_loop_hook_counter = UI_LOOP_POLL_INTERVAL;
-
-/* Actual hook to call to run through gdb's gui event loop */
-extern int (*deprecated_ui_loop_hook) (int signo);
-#endif /* NEED_UI_LOOP_HOOK */
-
 #ifndef INLINE
 #if defined(__GNUC__) && defined(__OPTIMIZE__)
 #define INLINE __inline__
@@ -1042,14 +1031,6 @@  sim_resume (SIM_DESC sd, int step, int siggnal)
 
       /* Writeback all the DATA / PC changes */
       SLOT_FLUSH ();
-
-#ifdef NEED_UI_LOOP_HOOK
-      if (deprecated_ui_loop_hook != NULL && ui_loop_hook_counter-- < 0)
-	{
-	  ui_loop_hook_counter = UI_LOOP_POLL_INTERVAL;
-	  deprecated_ui_loop_hook (0);
-	}
-#endif /* NEED_UI_LOOP_HOOK */
     }
   while ( !State.exception && !stop_simulator);