[4/5] sim: cr16: delete NEED_UI_LOOP_HOOK handling

Message ID 1427690802-26761-4-git-send-email-vapier@gentoo.org
State Committed
Headers

Commit Message

Mike Frysinger March 30, 2015, 4:46 a.m. UTC
  This hook is used only when linked into gdb, and cr16 doesn't have a gdb
port anymore.  Punt it.

Committed.
---
 sim/cr16/ChangeLog   |  7 +++++++
 sim/cr16/Makefile.in |  2 +-
 sim/cr16/interp.c    | 19 -------------------
 3 files changed, 8 insertions(+), 20 deletions(-)
  

Patch

diff --git a/sim/cr16/ChangeLog b/sim/cr16/ChangeLog
index 184d803..4564557 100644
--- a/sim/cr16/ChangeLog
+++ b/sim/cr16/ChangeLog
@@ -1,5 +1,12 @@ 
 2015-03-29  Mike Frysinger  <vapier@gentoo.org>
 
+	* Makefile.in (SIM_EXTRA_CFLAGS): Delete -DNEED_UI_LOOP_HOOK.
+	* interp.c [NEED_UI_LOOP_HOOK] (UI_LOOP_POLL_INTERVAL,
+	ui_loop_hook_counter, deprecated_ui_loop_hook): Delete.
+	(sim_resume) [NEED_UI_LOOP_HOOK]: Delete ui code.
+
+2015-03-29  Mike Frysinger  <vapier@gentoo.org>
+
 	* interp.c (old_segment_mapping, ins_type_counters, add_commas,
 	set_dmap_register, set_imap_register, HELD_SPI_IDX, HELD_SPU_IDX,
 	spu_register, spi_register, set_spi_register, set_spu_register):
diff --git a/sim/cr16/Makefile.in b/sim/cr16/Makefile.in
index de85cf8..b5908e7 100644
--- a/sim/cr16/Makefile.in
+++ b/sim/cr16/Makefile.in
@@ -22,7 +22,7 @@  SIM_RUN_OBJS = run.o
 
 SIM_OBJS = interp.o table.o simops.o endian.o sim-load.o
 SIM_EXTRA_CLEAN = clean-extra
-SIM_EXTRA_CFLAGS = -DNEED_UI_LOOP_HOOK -DSIM_USE_DEPRECATED_RUN_FRONTEND
+SIM_EXTRA_CFLAGS = -DSIM_USE_DEPRECATED_RUN_FRONTEND
 
 INCLUDE = cr16_sim.h $(srcroot)/include/gdb/callback.h targ-vals.h endian.c \
 	$(srcroot)/include/gdb/sim-cr16.h
diff --git a/sim/cr16/interp.c b/sim/cr16/interp.c
index c6d55f5..88c4a80 100644
--- a/sim/cr16/interp.c
+++ b/sim/cr16/interp.c
@@ -56,17 +56,6 @@  extern void sim_set_profile (int n);
 extern void sim_set_profile_size (int n);
 static INLINE uint8 *map_memory (unsigned phys_addr);
 
-#ifdef NEED_UI_LOOP_HOOK
-/* How often to run the ui_loop update, when in use */
-#define UI_LOOP_POLL_INTERVAL 0x14000
-
-/* Counter for the ui_loop_hook update */
-static long ui_loop_hook_counter = UI_LOOP_POLL_INTERVAL;
-
-/* Actual hook to call to run through gdb's gui event loop */
-extern int (*deprecated_ui_loop_hook) (int signo);
-#endif /* NEED_UI_LOOP_HOOK */
-
 #ifndef INLINE
 #if defined(__GNUC__) && defined(__OPTIMIZE__)
 #define INLINE __inline__
@@ -1095,14 +1084,6 @@  sim_resume (SIM_DESC sd, int step, int siggnal)
 
       /* Writeback all the DATA / PC changes */
       SLOT_FLUSH ();
-
-#ifdef NEED_UI_LOOP_HOOK
-      if (deprecated_ui_loop_hook != NULL && ui_loop_hook_counter-- < 0)
-        {
-          ui_loop_hook_counter = UI_LOOP_POLL_INTERVAL;
-          deprecated_ui_loop_hook (0);
-        }
-#endif /* NEED_UI_LOOP_HOOK */
     }
   while ( !State.exception && !stop_simulator);