sim: microblaze: use common configure options

Message ID 1427644235-26991-1-git-send-email-vapier@gentoo.org
State Committed
Headers

Commit Message

Mike Frysinger March 29, 2015, 3:50 p.m. UTC
  In preparation for converting to nrun, call the common functions that
are needed.  This doesn't produce any new warnings, and the generated
code should be the same.
---
 sim/microblaze/ChangeLog    |   7 +
 sim/microblaze/config.in    |  15 ++
 sim/microblaze/configure    | 417 +++++++++++++++++++++++++++++++++++++++++++-
 sim/microblaze/configure.ac |   5 +
 4 files changed, 442 insertions(+), 2 deletions(-)
  

Patch

diff --git a/sim/microblaze/ChangeLog b/sim/microblaze/ChangeLog
index c2c72a5..7ee66c5 100644
--- a/sim/microblaze/ChangeLog
+++ b/sim/microblaze/ChangeLog
@@ -1,3 +1,10 @@ 
+2015-03-29  Mike Frysinger  <vapier@gentoo.org>
+
+	* configure.ac: Call SIM_AC_OPTION_ENDIAN, SIM_AC_OPTION_ALIGNMENT,
+	SIM_AC_OPTION_HOSTENDIAN, SIM_AC_OPTION_ENVIRONMENT, and
+	SIM_AC_OPTION_INLINE.
+	* config.in, configure: Regenerate.
+
 2015-03-16  Mike Frysinger  <vapier@gentoo.org>
 
 	* interp.c: Strip trailing whitespace.
diff --git a/sim/microblaze/config.in b/sim/microblaze/config.in
index 5ded703..6003e58 100644
diff --git a/sim/microblaze/configure b/sim/microblaze/configure
index c7e82ec..af6e579 100755
diff --git a/sim/microblaze/configure.ac b/sim/microblaze/configure.ac
index 0daa1af..96d0ffd 100644
--- a/sim/microblaze/configure.ac
+++ b/sim/microblaze/configure.ac
@@ -5,6 +5,11 @@  sinclude(../common/acinclude.m4)
 
 SIM_AC_COMMON
 
+SIM_AC_OPTION_ENDIAN
+SIM_AC_OPTION_ALIGNMENT(STRICT_ALIGNMENT,STRICT_ALIGNMENT)
+SIM_AC_OPTION_HOSTENDIAN
+SIM_AC_OPTION_ENVIRONMENT
+SIM_AC_OPTION_INLINE
 SIM_AC_OPTION_WARNINGS
 
 SIM_AC_OUTPUT