sim: bfin: fix up linux-fixed-code.h generation more [PR sim/13160]

Message ID 1425966181-7672-1-git-send-email-vapier@gentoo.org
State Committed
Headers

Commit Message

Mike Frysinger March 10, 2015, 5:43 a.m. UTC
  Add a trailing semi-colon to the sed print command as the BSD sed
implementation wants it.  It's a nop otherwise and works fine on
GNU/etc... implementations too.

Committed.
---
 sim/bfin/ChangeLog   | 6 ++++++
 sim/bfin/Makefile.in | 2 +-
 2 files changed, 7 insertions(+), 1 deletion(-)
  

Patch

diff --git a/sim/bfin/ChangeLog b/sim/bfin/ChangeLog
index ff967d9..649cb6e 100644
--- a/sim/bfin/ChangeLog
+++ b/sim/bfin/ChangeLog
@@ -1,3 +1,9 @@ 
+2015-03-10  Mike Frysinger  <vapier@gentoo.org>
+
+	PR sim/13160
+	* Makefile.in ($(srcdir)/linux-fixed-code.h): Put a ; after the
+	print sed command for BSD compatibility.
+
 2015-03-08  Mike Frysinger  <vapier@gentoo.org>
 
 	PR sim/13160
diff --git a/sim/bfin/Makefile.in b/sim/bfin/Makefile.in
index a7f852d..941ffea 100644
--- a/sim/bfin/Makefile.in
+++ b/sim/bfin/Makefile.in
@@ -58,7 +58,7 @@  $(srcdir)/linux-fixed-code.h: @MAINTAINER_MODE_TRUE@ $(srcdir)/linux-fixed-code.
 		$(OBJDUMP_FOR_TARGET) -d -z linux-fixed-code.o > $@.dis; \
 		sed -n \
 			-e 's:^[^	]*	:0x:' \
-			-e '/^0x/{s:	.*::;s: *$$:,:;s: :, 0x:g;p}' \
+			-e '/^0x/{s:	.*::;s: *$$:,:;s: :, 0x:g;p;}' \
 			$@.dis; \
 		rm -f $@.dis; \
 		echo "};" \