Patchwork [1/9] Allow GDB to build against unreleased Guile 2.2

login
register
mail settings
Submitter Andy Wingo
Date April 9, 2014, 4:08 p.m.
Message ID <1397059725-18066-2-git-send-email-wingo@igalia.com>
Download mbox | patch
Permalink /patch/442/
State Changes Requested
Headers show

Comments

Andy Wingo - April 9, 2014, 4:08 p.m.
* gdb/configure:
* gdb/configure.ac (try_guile_versions): Allow building with guile 2.2.
---
 gdb/configure    | 5 +++--
 gdb/configure.ac | 2 +-
 2 files changed, 4 insertions(+), 3 deletions(-)

Patch

diff --git a/gdb/configure b/gdb/configure
index fd61bb5..307c6c9 100755
--- a/gdb/configure
+++ b/gdb/configure
@@ -3,7 +3,7 @@ 
 # Generated by GNU Autoconf 2.64.
 #
 # Copyright (C) 1992, 1993, 1994, 1995, 1996, 1998, 1999, 2000, 2001,
-# 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009 Free Software
+# 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009, 2014 Free Software
 # Foundation, Inc.
 #
 # This configure script is free software; the Free Software Foundation
@@ -8750,7 +8750,8 @@  fi
 
 
 
-try_guile_versions="guile-2.0"
+
+try_guile_versions="guile-2.2 guile-2.0"
 have_libguile=no
 case "${with_guile}" in
 no)
diff --git a/gdb/configure.ac b/gdb/configure.ac
index 494d711..ff84a2e 100644
--- a/gdb/configure.ac
+++ b/gdb/configure.ac
@@ -1154,7 +1154,7 @@  AC_MSG_RESULT([$with_guile])
 dnl We check guile with pkg-config.
 AC_PATH_PROG(pkg_config_prog_path, pkg-config, missing)
 
-try_guile_versions="guile-2.0"
+try_guile_versions="guile-2.2 guile-2.0"
 have_libguile=no
 case "${with_guile}" in
 no)