[RFA] Remove cleanup from frame_prepare_for_sniffer

Message ID 20171008225243.21921-1-tom@tromey.com
State New, archived
Headers

Commit Message

Tom Tromey Oct. 8, 2017, 10:52 p.m. UTC
  Currently frame_prepare_for_sniffer returns a cleanup.  This patch
changes it to return void, and exposes frame_cleanup_after_sniffer to
the caller.

Normally I would write an RAII class for this sort of thing; but
because there was just a single caller of frame_prepare_for_sniffer,
and because this caller is already using try/catch, I thought it
seemed ok to require explicit calls in this instance.

Regression tested by the buildbot.

gdb/ChangeLog
2017-10-08  Tom Tromey  <tom@tromey.com>

	* frame-unwind.c (frame_unwind_try_unwinder): Update.
	* frame.h (frame_cleanup_after_sniffer): Declare.
	(frame_prepare_for_sniffer): Return void.
	* frame.c (frame_cleanup_after_sniffer): No longer static.  Change
	type of argument.
	(frame_prepare_for_sniffer): Return void.
---
 gdb/ChangeLog      |  9 +++++++++
 gdb/frame-unwind.c | 12 ++++--------
 gdb/frame.c        | 13 +++++--------
 gdb/frame.h        | 13 +++++++++----
 4 files changed, 27 insertions(+), 20 deletions(-)
  

Comments

Simon Marchi Oct. 9, 2017, 2:08 a.m. UTC | #1
On 2017-10-08 06:52 PM, Tom Tromey wrote:
> Currently frame_prepare_for_sniffer returns a cleanup.  This patch
> changes it to return void, and exposes frame_cleanup_after_sniffer to
> the caller.
> 
> Normally I would write an RAII class for this sort of thing; but
> because there was just a single caller of frame_prepare_for_sniffer,
> and because this caller is already using try/catch, I thought it
> seemed ok to require explicit calls in this instance.
> 
> Regression tested by the buildbot.

I think it makes sense, LGTM.
  

Patch

diff --git a/gdb/frame-unwind.c b/gdb/frame-unwind.c
index 096631c58b..ede226abb0 100644
--- a/gdb/frame-unwind.c
+++ b/gdb/frame-unwind.c
@@ -97,10 +97,9 @@  static int
 frame_unwind_try_unwinder (struct frame_info *this_frame, void **this_cache,
                           const struct frame_unwind *unwinder)
 {
-  struct cleanup *old_cleanup;
   int res = 0;
 
-  old_cleanup = frame_prepare_for_sniffer (this_frame, unwinder);
+  frame_prepare_for_sniffer (this_frame, unwinder);
 
   TRY
     {
@@ -117,7 +116,7 @@  frame_unwind_try_unwinder (struct frame_info *this_frame, void **this_cache,
 	     thus most unwinders aren't able to determine if they're
 	     the best fit.  Keep trying.  Fallback prologue unwinders
 	     should always accept the frame.  */
-	  do_cleanups (old_cleanup);
+	  frame_cleanup_after_sniffer (this_frame);
 	  return 0;
 	}
       throw_exception (ex);
@@ -125,15 +124,12 @@  frame_unwind_try_unwinder (struct frame_info *this_frame, void **this_cache,
   END_CATCH
 
   if (res)
-    {
-      discard_cleanups (old_cleanup);
-      return 1;
-    }
+    return 1;
   else
     {
       /* Don't set *THIS_CACHE to NULL here, because sniffer has to do
 	 so.  */
-      do_cleanups (old_cleanup);
+      frame_cleanup_after_sniffer (this_frame);
       return 0;
     }
   gdb_assert_not_reached ("frame_unwind_try_unwinder");
diff --git a/gdb/frame.c b/gdb/frame.c
index afdc157ebd..17f7397aee 100644
--- a/gdb/frame.c
+++ b/gdb/frame.c
@@ -2864,11 +2864,9 @@  frame_stop_reason_symbol_string (enum unwind_stop_reason reason)
 /* Clean up after a failed (wrong unwinder) attempt to unwind past
    FRAME.  */
 
-static void
-frame_cleanup_after_sniffer (void *arg)
+void
+frame_cleanup_after_sniffer (struct frame_info *frame)
 {
-  struct frame_info *frame = (struct frame_info *) arg;
-
   /* The sniffer should not allocate a prologue cache if it did not
      match this frame.  */
   gdb_assert (frame->prologue_cache == NULL);
@@ -2893,16 +2891,15 @@  frame_cleanup_after_sniffer (void *arg)
 }
 
 /* Set FRAME's unwinder temporarily, so that we can call a sniffer.
-   Return a cleanup which should be called if unwinding fails, and
-   discarded if it succeeds.  */
+   If sniffing fails, the caller should be sure to call
+   frame_cleanup_after_sniffer.  */
 
-struct cleanup *
+void
 frame_prepare_for_sniffer (struct frame_info *frame,
 			   const struct frame_unwind *unwind)
 {
   gdb_assert (frame->unwind == NULL);
   frame->unwind = unwind;
-  return make_cleanup (frame_cleanup_after_sniffer, frame);
 }
 
 static struct cmd_list_element *set_backtrace_cmdlist;
diff --git a/gdb/frame.h b/gdb/frame.h
index 1b726108b9..190ce7623f 100644
--- a/gdb/frame.h
+++ b/gdb/frame.h
@@ -791,11 +791,16 @@  extern void info_locals_command (char *, int);
 extern void return_command (char *, int);
 
 /* Set FRAME's unwinder temporarily, so that we can call a sniffer.
-   Return a cleanup which should be called if unwinding fails, and
-   discarded if it succeeds.  */
+   If sniffing fails, the caller should be sure to call
+   frame_cleanup_after_sniffer.  */
 
-struct cleanup *frame_prepare_for_sniffer (struct frame_info *frame,
-					   const struct frame_unwind *unwind);
+extern void frame_prepare_for_sniffer (struct frame_info *frame,
+				       const struct frame_unwind *unwind);
+
+/* Clean up after a failed (wrong unwinder) attempt to unwind past
+   FRAME.  */
+
+extern void frame_cleanup_after_sniffer (struct frame_info *frame);
 
 /* Notes (cagney/2002-11-27, drow/2003-09-06):