Patchwork [1/5] gnu: calibre: Do not use python setuptools for building.

login
register
mail settings
Submitter Hartmut Goebel
Date Dec. 2, 2016, 2:55 p.m.
Message ID <1480690505-21501-2-git-send-email-h.goebel@crazy-compilers.com>
Download mbox | patch
Permalink /patch/18131/
State New
Headers show

Comments

Hartmut Goebel - Dec. 2, 2016, 2:55 p.m.
* gnu/packages/ebook.scm (calibre)[arguments]: Set #:use-setuptools?
to false.
---
 gnu/packages/ebook.scm | 3 +++
 1 file changed, 3 insertions(+)

Patch

diff --git a/gnu/packages/ebook.scm b/gnu/packages/ebook.scm
index ad18716..3843fb2 100644
--- a/gnu/packages/ebook.scm
+++ b/gnu/packages/ebook.scm
@@ -126,6 +126,9 @@ 
      `(#:python ,python-2
        #:test-target "check"
        #:tests? #f ; FIXME: enable once flake8 is packaged
+       ;; Calibre is using setuptools by itself, but the setup.py is not
+       ;; compatible with the shim wrapper (taken from pip) we are using.
+       #:use-setuptools? #f
        #:phases
        (modify-phases %standard-phases
          (add-before 'build 'configure