Patchwork gnu: mpv: Use lua@5.2.

login
register
mail settings
Submitter Andy Patterson
Date Nov. 14, 2016, 3:09 a.m.
Message ID <20161113220949.538f81a6@uwaterloo.ca>
Download mbox | patch
Permalink /patch/17446/
State New
Headers show

Comments

Andy Patterson - Nov. 14, 2016, 3:09 a.m.
Hi,

This patch re-enables lua support in mpv. After reading
waftools/checks/custom.py in the distribution, I came to the conclusion
that lua > 5.2 isn't supported, so I think this is the right approach.

Thanks,

--
Andy

From fc3b127ea206749cf91eb956e57083f9169f29fb Mon Sep 17 00:00:00 2001
From: Andy Patterson <ajpatter@uwaterloo.ca>
Date: Sun, 13 Nov 2016 21:53:57 -0500
Subject: [PATCH] gnu: mpv: Use lua@5.2.

* gnu/packages/video.scm (mpv)[inputs]: Use lua-5.2.
---
 gnu/packages/video.scm | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)
Marius Bakke - Nov. 14, 2016, 9:06 a.m.
Andy Patterson <ajpatter@uwaterloo.ca> writes:

> Hi,
>
> This patch re-enables lua support in mpv. After reading
> waftools/checks/custom.py in the distribution, I came to the conclusion
> that lua > 5.2 isn't supported, so I think this is the right approach.

Thanks for catching this, applied!

Patch

diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 2e336dd..4329d20 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -866,7 +866,9 @@  SVCD, DVD, 3ivx, DivX 3/4/5, WMV and H.264 movies.")
        ("libxrandr" ,libxrandr)
        ("libxscrnsaver" ,libxscrnsaver)
        ("libxv" ,libxv)
-       ("lua" ,lua)
+       ;; XXX: lua > 5.2 is not currently supported; see
+       ;; waftools/checks/custom.py
+       ("lua" ,lua-5.2)
        ("mesa" ,mesa)
        ("mpg123" ,mpg123)
        ("pulseaudio" ,pulseaudio)