Patchwork [6/6] gnu: Provide pytest to python-sqlalchemy-utils.

login
register
mail settings
Submitter Danny Milosavljevic
Date Nov. 5, 2016, 11:27 a.m.
Message ID <20161105112706.12089-7-dannym@scratchpost.org>
Download mbox | patch
Permalink /patch/17216/
State New
Headers show

Comments

Danny Milosavljevic - Nov. 5, 2016, 11:27 a.m.
* gnu/packages/python.scm (python-sqlalchemy-utils)[arguments]: Add pytest.
---
 gnu/packages/python.scm | 2 ++
 1 file changed, 2 insertions(+)
Marius Bakke - Nov. 5, 2016, 3:58 p.m.
Danny Milosavljevic <dannym@scratchpost.org> writes:

> * gnu/packages/python.scm (python-sqlalchemy-utils)[arguments]: Add pytest.

This is not [arguments], but [native-inputs]. That applies to the
previous patch as well!

> ---
>  gnu/packages/python.scm | 2 ++
>  1 file changed, 2 insertions(+)
>
> diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
> index 2d984bb..86a6eea 100644
> --- a/gnu/packages/python.scm
> +++ b/gnu/packages/python.scm
> @@ -3979,6 +3979,8 @@ automatically for you if you install this library.")
>      (propagated-inputs
>       `(("python-six" ,python-six)
>         ("python-sqlalchemy" ,python-sqlalchemy)))
> +    (native-inputs
> +     `(("python-pytest" ,python-pytest)))
>      (home-page "https://github.com/kvesteri/sqlalchemy-utils")
>      (synopsis "Various utility functions for SQLAlchemy")
>      (description

Why is this needed now, if it was working before? LGTM anyway.
Leo Famulari - Nov. 5, 2016, 7:13 p.m.
On Sat, Nov 05, 2016 at 03:58:16PM +0000, Marius Bakke wrote:
> Danny Milosavljevic <dannym@scratchpost.org> writes:
> 
> > * gnu/packages/python.scm (python-sqlalchemy-utils)[arguments]: Add pytest.
> 
> This is not [arguments], but [native-inputs]. That applies to the
> previous patch as well!
> 
> > ---
> >  gnu/packages/python.scm | 2 ++
> >  1 file changed, 2 insertions(+)
> >
> > diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
> > index 2d984bb..86a6eea 100644
> > --- a/gnu/packages/python.scm
> > +++ b/gnu/packages/python.scm
> > @@ -3979,6 +3979,8 @@ automatically for you if you install this library.")
> >      (propagated-inputs
> >       `(("python-six" ,python-six)
> >         ("python-sqlalchemy" ,python-sqlalchemy)))
> > +    (native-inputs
> > +     `(("python-pytest" ,python-pytest)))
> >      (home-page "https://github.com/kvesteri/sqlalchemy-utils")
> >      (synopsis "Various utility functions for SQLAlchemy")
> >      (description
> 
> Why is this needed now, if it was working before? LGTM anyway.

It does fail on core-updates:

https://hydra.gnu.org/build/1579077

Patch

diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 2d984bb..86a6eea 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3979,6 +3979,8 @@  automatically for you if you install this library.")
     (propagated-inputs
      `(("python-six" ,python-six)
        ("python-sqlalchemy" ,python-sqlalchemy)))
+    (native-inputs
+     `(("python-pytest" ,python-pytest)))
     (home-page "https://github.com/kvesteri/sqlalchemy-utils")
     (synopsis "Various utility functions for SQLAlchemy")
     (description