Patchwork [5/5] gnu: Update Sphinx to 1.4.6.

login
register
mail settings
Submitter Danny Milosavljevic
Date Oct. 7, 2016, 10:32 a.m.
Message ID <20161007103250.24046-6-dannym@scratchpost.org>
Download mbox | patch
Permalink /patch/16339/
State New
Headers show

Comments

Danny Milosavljevic - Oct. 7, 2016, 10:32 a.m.
* gnu/packages/python.scm (python-sphinx): Updated.
---
 gnu/packages/python.scm | 15 ++++++++++-----
 1 file changed, 10 insertions(+), 5 deletions(-)
Hartmut Goebel - Oct. 7, 2016, 11:14 a.m.
Am 07.10.2016 um 12:32 schrieb Danny Milosavljevic:
> +    (native-inputs
> +     `(("python-imagesize" ,python-imagesize)
> +       ("python-sphinx-alabaster-theme-0.7"
> +        ,python-sphinx-alabaster-theme-0.7)
> +       ("python-babel" ,python-babel)
> +       ("python-snowballstemmer" ,python-snowballstemmer)
> +       ("python-six" ,python-six)))
>      (inputs
>       `(("python-setuptools" ,python-setuptools)

These inputs are wrong (and already have been wrong). Please take the
change to correct the old ones, too.

These are required at run-time and thus need to be propagated-inputs:

    'six>=1.5',
    'Jinja2>=2.3',
    'Pygments>=2.0',
    'docutils>=0.11',
    'snowballstemmer>=1.1',
    'babel>=1.3,!=2.0',
    'alabaster>=0.7,<0.8',
    'imagesize',

These are required for building and testing only and thus have to be
native-inputs

        setuptools,
        'nose',
        'mock',  # it would be better for 'test:python_version in "2.6,2.7"'
        'simplejson',  # better:
'test:platform_python_implementation=="PyPy"'

Patch

diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 157a544..da5b63d 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2802,17 +2802,22 @@  reStructuredText.")
 (define-public python-sphinx
   (package
     (name "python-sphinx")
-    (version "1.2.3")
+    (version "1.4.6")
     (source
      (origin
        (method url-fetch)
-       (uri (string-append
-             "https://pypi.python.org/packages/source/S/Sphinx/Sphinx-"
-             version ".tar.gz"))
+       (uri (pypi-uri "Sphinx" version))
        (sha256
         (base32
-         "011xizm3jnmf4cvs5i6kgf6c5nn046h79i8j0vd0f27yw9j3p4wl"))))
+         "1lvr39ab5sjp894jshk39xidlxw9vc735882cgcfr4dlm4546hwy"))))
     (build-system python-build-system)
+    (native-inputs
+     `(("python-imagesize" ,python-imagesize)
+       ("python-sphinx-alabaster-theme-0.7"
+        ,python-sphinx-alabaster-theme-0.7)
+       ("python-babel" ,python-babel)
+       ("python-snowballstemmer" ,python-snowballstemmer)
+       ("python-six" ,python-six)))
     (inputs
      `(("python-setuptools" ,python-setuptools)
        ("python-jinja2" ,python-jinja2)