Patchwork Add ati support to xorg configuration.

login
register
mail settings
Submitter Dmitry Nikolaev
Date Oct. 5, 2016, 9:16 p.m.
Message ID <CAH3JXcGjTtdxemRep8jfqQfxmR+wnMQGbgzEFc10TFetp7ut2Q@mail.gmail.com>
Download mbox | patch
Permalink /patch/16287/
State New
Headers show

Comments

Dmitry Nikolaev - Oct. 5, 2016, 9:16 p.m.
Hi. Without this patch I couldn't run X on my Radeon card.

Dmitry Nikolaev
Marius Bakke - Oct. 6, 2016, 12:29 p.m.
Dmitry Nikolaev <cameltheman@gmail.com> writes:

> Hi. Without this patch I couldn't run X on my Radeon card.

Thanks! This looks good to me, but please add a commit message that
follows our conventions. Check "git log --grep service" for examples.

> Dmitry Nikolaev
> From 25f8f50e1bd6efaee0008283ca1de8b1fe951d7e Mon Sep 17 00:00:00 2001
> From: 8p8c <cameltheman@gmail.com>
> Date: Thu, 6 Oct 2016 00:09:00 +0300
> Subject: [PATCH] Add Ati drivers to xorg configuration
>
> ---
>  gnu/services/xorg.scm | 2 ++
>  1 file changed, 2 insertions(+)
>
> diff --git a/gnu/services/xorg.scm b/gnu/services/xorg.scm
> index d098d83..ccac677 100644
> --- a/gnu/services/xorg.scm
> +++ b/gnu/services/xorg.scm
> @@ -108,6 +108,7 @@ Section \"Files\"
>    FontPath \"" font-adobe75dpi "/share/fonts/X11/75dpi\"
>    ModulePath \"" xf86-video-vesa "/lib/xorg/modules/drivers\"
>    ModulePath \"" xf86-video-fbdev "/lib/xorg/modules/drivers\"
> +  ModulePath \"" xf86-video-ati "/lib/xorg/modules/drivers\"
>    ModulePath \"" xf86-video-modesetting "/lib/xorg/modules/drivers\"
>    ModulePath \"" xf86-video-cirrus "/lib/xorg/modules/drivers\"
>    ModulePath \"" xf86-video-intel "/lib/xorg/modules/drivers\"
> @@ -145,6 +146,7 @@ EndSection
>  (define %default-xorg-modules
>    (list xf86-video-vesa
>          xf86-video-fbdev
> +        xf86-video-ati
>          xf86-video-modesetting
>          xf86-video-cirrus
>          xf86-video-intel
> -- 
> 2.10.0
=?utf-8?B?5a6L5paH5q2m?= - Oct. 6, 2016, 1 p.m.
Dmitry Nikolaev <cameltheman@gmail.com> writes:

> Hi. Without this patch I couldn't run X on my Radeon card.

Applied, thanks!

Just curious, does it work for you without firmwares?

Patch

From 25f8f50e1bd6efaee0008283ca1de8b1fe951d7e Mon Sep 17 00:00:00 2001
From: 8p8c <cameltheman@gmail.com>
Date: Thu, 6 Oct 2016 00:09:00 +0300
Subject: [PATCH] Add Ati drivers to xorg configuration

---
 gnu/services/xorg.scm | 2 ++
 1 file changed, 2 insertions(+)

diff --git a/gnu/services/xorg.scm b/gnu/services/xorg.scm
index d098d83..ccac677 100644
--- a/gnu/services/xorg.scm
+++ b/gnu/services/xorg.scm
@@ -108,6 +108,7 @@  Section \"Files\"
   FontPath \"" font-adobe75dpi "/share/fonts/X11/75dpi\"
   ModulePath \"" xf86-video-vesa "/lib/xorg/modules/drivers\"
   ModulePath \"" xf86-video-fbdev "/lib/xorg/modules/drivers\"
+  ModulePath \"" xf86-video-ati "/lib/xorg/modules/drivers\"
   ModulePath \"" xf86-video-modesetting "/lib/xorg/modules/drivers\"
   ModulePath \"" xf86-video-cirrus "/lib/xorg/modules/drivers\"
   ModulePath \"" xf86-video-intel "/lib/xorg/modules/drivers\"
@@ -145,6 +146,7 @@  EndSection
 (define %default-xorg-modules
   (list xf86-video-vesa
         xf86-video-fbdev
+        xf86-video-ati
         xf86-video-modesetting
         xf86-video-cirrus
         xf86-video-intel
-- 
2.10.0