Patchwork [3/3] gnu: vlc: Add inputs.

login
register
mail settings
Submitter Alex Vong
Date Sept. 10, 2016, 3:08 a.m.
Message ID <87r38sih99.fsf@gmail.com>
Download mbox | patch
Permalink /patch/15483/
State New
Headers show

Comments

Leo Famulari - Sept. 20, 2016, 8:09 p.m.
On Sat, Sep 10, 2016 at 11:08:18AM +0800, Alex Vong wrote:
> From b9e30604e432586c89c5e33b27ba609852efd399 Mon Sep 17 00:00:00 2001
> From: Alex Vong <alexvong1995@gmail.com>
> Date: Tue, 30 Aug 2016 02:30:57 +0800
> Subject: [PATCH 3/3] gnu: vlc: Add inputs.
> 
> * gnu/packages/video.scm (vlc)[inputs]: Add eudev, faad2, fluidsynth,
>   gnome-vfs, gst-plugins-base, gtk+-2, jack-2, libass, libavc1394,
>   libbluray, libcaca, libdca, libdvdnav, libdvdread, libmpeg2,
>   libmodplug, libmtp, libnotify, libraw1394, libshout, librsvg, libupnp,
>   libva, libvdpau, samba, taglib, twolame.

My question is similar to the one for the last patch. Can you check on
<https://hydra.gnu.org> if these packages build for all our supported
architectures? If so, okay for me.
Ricardo Wurmus - Oct. 10, 2016, 2:55 p.m.
Alex Vong <alexvong1995@gmail.com> writes:


> * gnu/packages/video.scm (vlc)[inputs]: Add eudev, faad2, fluidsynth,
>   gnome-vfs, gst-plugins-base, gtk+-2, jack-2, libass, libavc1394,
>   libbluray, libcaca, libdca, libdvdnav, libdvdread, libmpeg2,
>   libmodplug, libmtp, libnotify, libraw1394, libshout, librsvg, libupnp,
>   libva, libvdpau, samba, taglib, twolame.

Please use “jack-1” instead of “jack-2”.  They both work but we use
“jack-1” everywhere.

“jack-2” offers DBUS activation — if a user wants to have this they can
install “jack-2” into their profile and it will work just fine with
applications that were linked with “jack-1”.

In short: “jack-2” is only there for users who want DBUS support in
their JACK server, “jack-1” is for everyone and everything else.

~~ Ricardo
Alex Vong - Oct. 10, 2016, 3:37 p.m.
Hello,

Ricardo Wurmus <rekado@elephly.net> writes:

> Alex Vong <alexvong1995@gmail.com> writes:
>
>
>> * gnu/packages/video.scm (vlc)[inputs]: Add eudev, faad2, fluidsynth,
>>   gnome-vfs, gst-plugins-base, gtk+-2, jack-2, libass, libavc1394,
>>   libbluray, libcaca, libdca, libdvdnav, libdvdread, libmpeg2,
>>   libmodplug, libmtp, libnotify, libraw1394, libshout, librsvg, libupnp,
>>   libva, libvdpau, samba, taglib, twolame.
>
> Please use “jack-1” instead of “jack-2”.  They both work but we use
> “jack-1” everywhere.
>
> “jack-2” offers DBUS activation — if a user wants to have this they can
> install “jack-2” into their profile and it will work just fine with
> applications that were linked with “jack-1”.
>
> In short: “jack-2” is only there for users who want DBUS support in
> their JACK server, “jack-1” is for everyone and everything else.
>
> ~~ Ricardo

I think the new patch I send today uses jack-1 instead of jack-2. I must
have forgotten to mention I make the switch.

Cheers,
Alex

Patch

From b9e30604e432586c89c5e33b27ba609852efd399 Mon Sep 17 00:00:00 2001
From: Alex Vong <alexvong1995@gmail.com>
Date: Tue, 30 Aug 2016 02:30:57 +0800
Subject: [PATCH 3/3] gnu: vlc: Add inputs.

* gnu/packages/video.scm (vlc)[inputs]: Add eudev, faad2, fluidsynth,
  gnome-vfs, gst-plugins-base, gtk+-2, jack-2, libass, libavc1394,
  libbluray, libcaca, libdca, libdvdnav, libdvdread, libmpeg2,
  libmodplug, libmtp, libnotify, libraw1394, libshout, librsvg, libupnp,
  libva, libvdpau, samba, taglib, twolame.
---
 gnu/packages/video.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)

diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index a041666..e791dbf 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -60,9 +60,13 @@ 
   #:use-module (gnu packages gl)
   #:use-module (gnu packages glib)
   #:use-module (gnu packages guile)
+  #:use-module (gnu packages gnome)
   #:use-module (gnu packages gnupg)
+  #:use-module (gnu packages gstreamer)
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages image)
+  #:use-module (gnu packages libupnp)
+  #:use-module (gnu packages libusb)
   #:use-module (gnu packages linux)
   #:use-module (gnu packages lua)
   #:use-module (gnu packages mp3)
@@ -74,6 +78,7 @@ 
   #:use-module (gnu packages pulseaudio)
   #:use-module (gnu packages python)
   #:use-module (gnu packages qt)
+  #:use-module (gnu packages samba)
   #:use-module (gnu packages sdl)
   #:use-module (gnu packages ssh)
   #:use-module (gnu packages texinfo)
@@ -611,20 +616,44 @@  audio/video codec library.")
      `(("alsa-lib" ,alsa-lib)
        ("avahi" ,avahi)
        ("dbus" ,dbus)
+       ("eudev" ,eudev)
+       ("faad2" ,faad2)
        ("flac" ,flac)
        ("ffmpeg" ,ffmpeg-2.8)               ;fails to build against ffmpeg 3.0
+       ("fluidsynth" ,fluidsynth)
        ("fontconfig" ,fontconfig)
        ("freetype" ,freetype)
+       ("gnome-vfs" ,gnome-vfs) ; FIXME: the build system cannot detect it
        ("gnutls" ,gnutls)
+       ("gst-plugins-base" ,gst-plugins-base)
+       ("gtk+" ,gtk+-2)
+       ("jack" ,jack-2)
        ("liba52" ,liba52)
+       ("libass" ,libass)
+       ("libavc1394" ,libavc1394)
+       ("libbluray" ,libbluray)
+       ("libcaca" ,libcaca)
+       ("libdca" ,libdca)
        ("libcddb" ,libcddb)
+       ("libdvdnav" ,libdvdnav)
+       ("libdvdread" ,libdvdread)
        ("libgcrypt" ,libgcrypt)
        ("libkate" ,libkate)
        ("libmad" ,libmad)
+       ("libmpeg2" ,libmpeg2)
+       ("libmodplug" ,libmodplug)
+       ("libmtp" ,libmtp)
+       ("libnotify" ,libnotify)
        ("libogg" ,libogg)
        ("libpng" ,libpng)
+       ("libraw1394" ,libraw1394)
        ("libsamplerate" ,libsamplerate)
+       ("libshout" ,libshout)
        ("libssh2" ,libssh2)
+       ("librsvg" ,librsvg)
+       ("libupnp" ,libupnp)
+       ("libva" ,libva)
+       ("libvdpau" ,libvdpau)
        ("libvorbis" ,libvorbis)
        ("libtheora" ,libtheora)
        ("libxext" ,libxext)
@@ -641,9 +670,12 @@  audio/video codec library.")
        ("qt" ,qt) ; FIXME: reenable modular qt after update - requires building
        ;("qtbase" ,qtbase) with -std=gnu++11.
        ;("qtx11extras" ,qtx11extras)
+       ("samba" ,samba)
        ("sdl" ,sdl)
        ("sdl-image" ,sdl-image)
        ("speex" ,speex)
+       ("taglib" ,taglib)
+       ("twolame" ,twolame)
        ("xcb-util-keysyms" ,xcb-util-keysyms)))
     (arguments
      `(#:configure-flags
-- 
2.10.0