Patchwork [03/22] gnu: Add perl-parse-yapp.

login
register
mail settings
Submitter Ben Woodcroft
Date July 27, 2016, 12:54 p.m.
Message ID <f0cfb2a3aaaa765bae862f6d18147f10e653536b.1469622378.git.donttrustben@gmail.com>
Download mbox | patch
Permalink /patch/14025/
State New
Headers show

Comments

Ben Woodcroft - July 27, 2016, 12:54 p.m.
* gnu/packages/perl.scm (perl-parse-yapp): New variable.
---
 gnu/packages/perl.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)

Patch

diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 844178a..76eeee3 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -6490,6 +6490,27 @@  YAML-style files, written with as little code as possible, reducing load time
 and memory overhead.")
     (license (package-license perl))))
 
+(define-public perl-parse-yapp
+  (package
+    (name "perl-parse-yapp")
+    (version "1.05")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "mirror://cpan/authors/id/F/FD/FDESAR/Parse-Yapp-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "0azjqqf4m7nkfgmmj4q77vy9sdgg01wn8xxv40bq3pis93xnr2i2"))))
+    (build-system perl-build-system)
+    (home-page "http://search.cpan.org/dist/Parse-Yapp")
+    (synopsis "Generate and use LALR parsers")
+    (description "This package compiles yacc-like @dfn{Look Ahead LR} (LALR)
+grammars to generate Perl object oriented parser modules.")
+    (license (package-license perl))))
+
 
 ;;; Some packaged modules need versions of core modules that are newer than
 ;;; those in our perl 5.16.1.