Typo: Rename HAVE_CLONE3_WAPPER to HAVE_CLONE3_WRAPPER

Message ID CAMe9rOo3WNCrqHb3NpdvcGKXApjD-pifNBU5gN3e1ph2NZ2VaQ@mail.gmail.com
State Committed
Headers
Series Typo: Rename HAVE_CLONE3_WAPPER to HAVE_CLONE3_WRAPPER |

Checks

Context Check Description
dj/TryBot-apply_patch success Patch applied to master at the time it was sent
dj/TryBot-32bit fail Patch series failed to apply

Commit Message

H.J. Lu July 28, 2021, 5:22 p.m. UTC
  On Tue, Jul 27, 2021 at 9:59 PM Florian Weimer via Libc-alpha
<libc-alpha@sourceware.org> wrote:
>
> * Andreas K. Huettel via Libc-alpha:
>
> > Semi-related...
> >
> >>    int ret;
> >> -#ifdef HAVE_CLONE3_WAPPER
> >> -  /* Try clone3 first.  */
> >> -  int saved_errno = errno;
> >
> > shouldn't this be WRAPPER ?
> >
> > (It seems to be consistent in the code, so no harm done so far...)
>
> Yes, it should be.  And yes, it's currently consistent.  But it's
> confusing if you search for it and don't make the typo.
>
> Thanks,
> Florian
>

Here is the patch.   OK for master?
  

Comments

Adhemerval Zanella July 28, 2021, 5:35 p.m. UTC | #1
On 28/07/2021 14:22, H.J. Lu via Libc-alpha wrote:
> On Tue, Jul 27, 2021 at 9:59 PM Florian Weimer via Libc-alpha
> <libc-alpha@sourceware.org> wrote:
>>
>> * Andreas K. Huettel via Libc-alpha:
>>
>>> Semi-related...
>>>
>>>>    int ret;
>>>> -#ifdef HAVE_CLONE3_WAPPER
>>>> -  /* Try clone3 first.  */
>>>> -  int saved_errno = errno;
>>>
>>> shouldn't this be WRAPPER ?
>>>
>>> (It seems to be consistent in the code, so no harm done so far...)
>>
>> Yes, it should be.  And yes, it's currently consistent.  But it's
>> confusing if you search for it and don't make the typo.
>>
>> Thanks,
>> Florian
>>
> 
> Here is the patch.   OK for master?
> 


LGTM, thanks.
  

Patch

From c25c32165d8b7c506442fdc0304f7a3a223e1f42 Mon Sep 17 00:00:00 2001
From: "H.J. Lu" <hjl.tools@gmail.com>
Date: Wed, 28 Jul 2021 10:19:08 -0700
Subject: [PATCH] Typo: Rename HAVE_CLONE3_WAPPER to HAVE_CLONE3_WRAPPER

---
 sysdeps/unix/sysv/linux/clone-internal.c | 2 +-
 sysdeps/unix/sysv/linux/i386/sysdep.h    | 2 +-
 sysdeps/unix/sysv/linux/x86_64/sysdep.h  | 2 +-
 3 files changed, 3 insertions(+), 3 deletions(-)

diff --git a/sysdeps/unix/sysv/linux/clone-internal.c b/sysdeps/unix/sysv/linux/clone-internal.c
index 1e7a8f6b35..979f7880be 100644
--- a/sysdeps/unix/sysv/linux/clone-internal.c
+++ b/sysdeps/unix/sysv/linux/clone-internal.c
@@ -48,7 +48,7 @@  __clone_internal (struct clone_args *cl_args,
 		  int (*func) (void *arg), void *arg)
 {
   int ret;
-#ifdef HAVE_CLONE3_WAPPER
+#ifdef HAVE_CLONE3_WRAPPER
   /* Try clone3 first.  */
   int saved_errno = errno;
   ret = __clone3 (cl_args, sizeof (*cl_args), func, arg);
diff --git a/sysdeps/unix/sysv/linux/i386/sysdep.h b/sysdeps/unix/sysv/linux/i386/sysdep.h
index 3927a1a6e0..8a9911b7ac 100644
--- a/sysdeps/unix/sysv/linux/i386/sysdep.h
+++ b/sysdeps/unix/sysv/linux/i386/sysdep.h
@@ -291,7 +291,7 @@  struct libc_do_syscall_args
 # define HAVE_TIME_VSYSCALL             "__vdso_time"
 # define HAVE_CLOCK_GETRES_VSYSCALL     "__vdso_clock_getres"
 
-# define HAVE_CLONE3_WAPPER		1
+# define HAVE_CLONE3_WRAPPER		1
 
 # undef HAVE_INTERNAL_BRK_ADDR_SYMBOL
 # define HAVE_INTERNAL_BRK_ADDR_SYMBOL 1
diff --git a/sysdeps/unix/sysv/linux/x86_64/sysdep.h b/sysdeps/unix/sysv/linux/x86_64/sysdep.h
index f26ffc68ae..327e59388b 100644
--- a/sysdeps/unix/sysv/linux/x86_64/sysdep.h
+++ b/sysdeps/unix/sysv/linux/x86_64/sysdep.h
@@ -377,7 +377,7 @@ 
 # define HAVE_GETCPU_VSYSCALL		"__vdso_getcpu"
 # define HAVE_CLOCK_GETRES64_VSYSCALL   "__vdso_clock_getres"
 
-# define HAVE_CLONE3_WAPPER			1
+# define HAVE_CLONE3_WRAPPER			1
 
 # define SINGLE_THREAD_BY_GLOBAL		1
 
-- 
2.31.1